Sign in to follow this  
Honda_Boy

Video Info Program

Recommended Posts

Well my friend's laptop is missing it's drivers and I have no clue what devices are in the system. I can't find the system on eMachines website. All I know is that it has a Sempron 2800+ and 512MB of RAM, PC2700 I believe. Thanks for help folks.

Edited by Honda_Boy

Share this post


Link to post
Share on other sites

nevermind, I found one. I'd been sittin' here forever tryin to think of the program I had known of. I was hopin ya'll would remind me but I remembered it.

It was CPU-Z.

Share this post


Link to post
Share on other sites

Well i know that the chipset on this thing is an ATI RS482. BUT, I'm not sure of what the video adapter is called and I can't seem to find drivers that'll install both. I have one set but it says it can't find the display drivers. SO, I nned something that scan the laptop and tell me what exactly the video chip is (The GPU I guess but I doubt this thing has a dedicated one). SO any help on this new problem would be greatly appreciated.

Share this post


Link to post
Share on other sites
Well i know that the chipset on this thing is an ATI RS482. BUT, I'm not sure of what the video adapter is called and I can't seem to find drivers that'll install both. I have one set but it says it can't find the display drivers. SO, I nned something that scan the laptop and tell me what exactly the video chip is (The GPU I guess but I doubt this thing has a dedicated one). SO any help on this new problem would be greatly appreciated.

Generally google and driverguide.com will do the trick. You can search for the ATI chipset on driverguide and find what is needed (it just takes a quick sign up)

Share this post


Link to post
Share on other sites

already tried driverguide. nothing. BUT it doesn't help that I don't know everything. thats why i need a program like I'm asking for. NOW, the x300/x550 drivers seem to be working but I'm sure if they are the correct ones.

Share this post


Link to post
Share on other sites

a little more info like model of the laptop would be helpful. I would boot it with any live version of linux then run this command

[email protected] ~ $ /usr/sbin/lspci
00:00.0 Host bridge: ATI Technologies Inc Unknown device 5a31 (rev 01)
00:01.0 PCI bridge: ATI Technologies Inc RS480 PCI Bridge
00:13.0 USB Controller: ATI Technologies Inc IXP SB400 USB Host Controller
00:13.1 USB Controller: ATI Technologies Inc IXP SB400 USB Host Controller
00:13.2 USB Controller: ATI Technologies Inc IXP SB400 USB2 Host Controller
00:14.0 SMBus: ATI Technologies Inc IXP SB400 SMBus Controller (rev 11)
00:14.1 IDE interface: ATI Technologies Inc Standard Dual Channel PCI IDE Controller ATI
00:14.3 ISA bridge: ATI Technologies Inc IXP SB400 PCI-ISA Bridge
00:14.4 PCI bridge: ATI Technologies Inc IXP SB400 PCI-PCI Bridge
00:14.5 Multimedia audio controller: ATI Technologies Inc IXP SB400 AC'97 Audio Controller (rev 02)
00:14.6 Modem: ATI Technologies Inc ATI SB400 - AC'97 Modem Controller (rev 02)
01:05.0 VGA compatible controller: ATI Technologies Inc RC410 [Radeon Xpress 200M]
09:01.0 CardBus bridge: Texas Instruments PCI1510 PC card Cardbus Controller
09:02.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL-8139/8139C/8139C+ (rev 10)
09:04.0 Ethernet controller: Atheros Communications, Inc. AR5005G 802.11abg NIC (rev 01)

I use linux to find out what drivers I need for my windows install all of the time. This is from my laptop. It tells me this info about my graphic chipset

01:05.0 VGA compatible controller: ATI Technologies Inc RC410 [Radeon Xpress 200M]

Share this post


Link to post
Share on other sites

big problem. the model is oddly absent from the notebook and I can't find it anywhere.

doesn't anyone know of a system info program? I really need something that'll tell me what this dang thing has. so far CPU-Z has told me this thing has an ATI RS482 Northbridge and an ATI SB400 Southbridge. Also it has an AMD Sempron 2800+ and 512MB of memory, PC2700 I believe. The video I'm not sure on but the Radeon X300/X550 drivers seem to be working. I do not have catalyst installed though because it refused to install.

Share this post


Link to post
Share on other sites

do you have microsoft .NET framework installed? I think the catalyst control center depends on it.

If your drivers seems to be working well, I would not worry about it.

Edited by shanenin

Share this post


Link to post
Share on other sites

breakthrough i discovered a few things. I believe this particular series of eMachines are rebranded Arimas. It has the Arima Model number (which I believe is incorrect anyhow) but is missing the eMachines one. One source says it is a W6420. Wrong but close. According to eMachines site, the W6420 has a turion processor with an express 200 chipset and x300 video. Well my source said that's exactly what it was. the wrong model number must be printed on this laptop. The actual eMachine model is a W6405. So now that I have the correct info I'm ready to rock.

Share this post


Link to post
Share on other sites

Fun isn't it - this is about 25% of the work I do everyday!

Now I know why my boss hired me

BTW - you're really dominated this thread!

Edited by xxkbxx

Share this post


Link to post
Share on other sites

Hmm, I need to report this to the shop I applied at. He's already seen my building and upgrade work. Now he can see my repair work. This poor laptop was going through hell with spyware, adware and viruses. Plus the jackass this laptop actually belongs to deleted and uninstalled too much. I managed to keep it running without a total format and reinstall (which I was about to do). But luckily I discovered this puppy's info. Actually the drivers for both the W6405 and the W6420 were one and the same. Turns out this particualr laptop is running on a RS482 NB and a SB400 SB with an ATI Express 200 Video chipset. I do not currently work for any computer places but I do this stuff all the time. I actually work at a BBQ joint. It sucks.

P.S. I've helped my boss with his laptop a few times.

Edited by Honda_Boy

Share this post


Link to post
Share on other sites
Hmm, I need to report this to the shop I applied at. He's already seen my building and upgrade work. Now he can see my repair work. This poor laptop was going through hell with spyware, adware and viruses. Plus the jackass this laptop actually belongs to deleted and uninstalled too much. I managed to keep it running without a total format and reinstall (which I was about to do). But luckily I discovered this puppy's info. Actually the drivers for both the W6405 and the W6420 were one and the same. Turns out this particualr laptop is running on a RS482 NB and a SB400 SB with an ATI Express 200 Video chipset. I do not currently work for any computer places but I do this stuff all the time. I actually work at a BBQ joint. It sucks.

P.S. I've helped my boss with his laptop a few times.

Switch up to the computer biz - believe today I re-disassemblying a laptop, removing its mobo, and changing out the power connector

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this