Sponsored By

Mychal007

Yahoo And Msn Messenger

Recommended Posts

I've got another question. I was curious as to why my GAIM Yahoo and MSN Messenger look so out-of-date?. Don't get me wrong, it works perfectly fine but it just looks weird and doesn't look the same as it does on Windows XP. On both, you can't log in as invisible and the whole set up looks really old. What can or is there anything I can do about this?

Share this post


Link to post
Share on other sites

if you want and are willing to learn a little more about Linux, you can compile and install the latest version of Gaim. it's fairly easy really, but you need certain files to be able to do it

Share this post


Link to post
Share on other sites

you will find a lot of the gnu/linux programs are not as polished as some of the windows programs. I suppose this is because most of them are produced by people for free with thier spare time. Programs like photoshop, aim, and yahoo messenger have huge amounts of paid programmers working 40 hour work weeks just doing that task. The people who work an gaim, just do it for fun(no pay) on the weekends.

Share this post


Link to post
Share on other sites

Well someone would be kind enough to walk me through the process, I'd certainly appreciate it.. I'm doing this Linux Newbie Tutorial so I'm beginning to like it more and more.

Edited by Mychal007

Share this post


Link to post
Share on other sites

before we start, what version of Gaim are you using? start the program then open the buddy list and click on help and about. If it is 1.5.0 then you have the newest stable version out. otherwise we will be installing the 2.0.0 beta version.

I forgot to mention, Gaim doesn't have the ability to log in as invisible, however you can put yourself in invisible mode after loggin in.

Share this post


Link to post
Share on other sites

An Ubuntu user built a deb package of gaim2 and has it available for download here.

Edited by naraku9333

Share this post


Link to post
Share on other sites

I don't know what I'm doing (yet). I'm not actually good at downloading stuff in Linux unless someone walks me through it. Then I make little notes to myself so that way, should the problem occur again, I'll know what going on. So I have no idea what to do with the link. :rolleyes:

Share this post


Link to post
Share on other sites

I am downloading the file now to test it out on Breezy, if there are any problems i will let you all know.

Share this post


Link to post
Share on other sites

ok, I have tried 3 times to install this program. unfortunately when they made the ubuntu Deb package they did it on Dapper Drake, which is the next release due out in June. At this time the Dependency requirements for installation is not readily done on the Breezy Badger version as well as Breaks packages on ubuntu. even when trying to install from actual source files from the Gaim website

On the simple one step version available, it uninstalls gaim 1.5 but then you get an update warning that reinstalls Gaim 1.5 and uninstalls the 2.0 beta. Afterwards it then uninstalls the Ubuntu-Desktop which is responsible for notifying you of and installing any package upgrades on ubuntu.

t this point we have run into dependancy hell for this install.

Share this post


Link to post
Share on other sites

you could try and build the package from source code. That means you will be changing the progamming code into a bianary file. I will give you directions that will install it in a different place then you current copy is installed. This way you will have both the old and new version of gaim installed. Plus it will not interfere with your other installed librarys(I think)

first you will need to install some developmental packages. These are needed to compile the program

sudo apt-get install build-essential
sudo apt-get install x-window-system-dev
sudo apt-get install libgtk2.0-dev

Now you need to download the gaim-2.0 beta package. I like to use the wget command

wget http://easynews.dl.sourceforge.net/sourceforge/gaim/gaim-2.0.0beta2.tar.bz2

after downloading the package you will need to untar it(like unzipping). The following command will do this

tar -xjf gaim-2.0.0beta2.tar.bz2

now you need to move into the gaim directory. Do the following command

cd gaim-2.0.0beta2

now that you are inside the gaim directory. you can build and install your program. This next command will ckeck to see if you have all of the nessesary stuff needed to build gaim. If you are missing anything, it will tell you what needs to be installed. If you get an error let me know what it is

./configure prefix=/opt

this next command will compile your program

make

if the previous command did not end with an error message you can install gaim like this

sudo make install

now to run the new version of gaim. type this command into your terminal. This is the full path(location) of your executable

/opt/bin/gaim

Edited by shanenin

Share this post


Link to post
Share on other sites

Very good instructions shanenin! :thumbsup:

I had considered installing 2.0 beta just recently but blew it off (didn't seem that important and not really any mention of exciting new features) but said what the hell....

Your instructions are spot on and should return no errors.

As far as how 2.0 runs/is/looks etc.....same old-same old with one very cool exception that'll make some users pretty happy. There's a "use status of last exit at startup" checkbox in the prefs, which enables users to sign on as invisible...I found that a minor annoyance and I guess it's somewhat of a gripe with most users.

Share this post


Link to post
Share on other sites

Hi Shanenin

I followed the directions you gave me and with success was able to enable both my Yahoo and AIM/ICQ Messenger accounts and they look wonderful now. However, when I tried to enable my MSN Messenger I received this messege: email (My Name) (MSN) Disconnected. email (My Name) (MSN) was disconnected due to an error. SSL Support is needed for MSN. Please install a Supported SSL library. See http://gaim.sf.net/faq-ssl.php for more information. The account has been disabled . Correct the error and reenable the account to connect.

Help!

Edit: email address removed to prevent email farming bots from collecting your email address and spamming your email account. Dragon

Share this post


Link to post
Share on other sites

you probably will need to recompile(build again) gaim with ssl support. Let me do a little research. I This should be easy to correct.

Share this post


Link to post
Share on other sites

I have not tested this, but it should work. you first need to install your ssl librarays

sudo apt-get install libgnutls10-dev

then you need to do these steps over, but change the ./configure command

./configure prefix=/opt  --enable-gnutls=yes
make
sudo make install

Share this post


Link to post
Share on other sites

from the site you pointed to.. ??

Ubuntu (Warty 4.10 & Hoary 5.04)

If you want to compile from source, make sure you have libgnutls10-dev installed.

Lars-Erik Labori provided a nice easy to follow guide:

First of all, you need to remove the old ubuntu Gaim version:

$ sudo apt-get remove gaim

1. You need to download the latest Gaim source from here.

2. You need to install the GNU TLS library development files:

$ sudo apt-get install libgnutls10-dev

3. Compile Gaim:

$ ./configure --enable-gnutls=yes

$ sudo make

$ sudo make install

Your new Gaim should be up and running.

Share this post


Link to post
Share on other sites

I got thrown off because I got two different set of directions :(

shanenin when I typed the sudo apt-get install libgnutls10-dev command you gave me, I got this messege:

Reading package lists... Done

Building dependency tree... Done

E: Couldn't find package libgnutsls10-dev

I never got to step 2 because of the above messege. And what did you mean by:

then you need to do these steps over, but change the ./configure command

./configure prefix=/opt --enable-gnutls=yes

make

sudo make install

Ya'll know I'm a step by step person so I got really lost.

Then I really got confused when iccaros instructed me on this part.

Ubuntu (Warty 4.10 & Hoary 5.04)

If you want to compile from source, make sure you have libgnutls10-dev installed.

Lars-Erik Labori provided a nice easy to follow guide:

First of all, you need to remove the old ubuntu Gaim version:

$ sudo apt-get remove gaim

1. You need to download the latest Gaim source from here.

2. You need to install the GNU TLS library development files:

$ sudo apt-get install libgnutls10-dev

3. Compile Gaim:

$ ./configure --enable-gnutls=yes

$ sudo make

$ sudo make install

Your new Gaim should be up and running.

First I type in sudo apt-get remove gaim. FYI Gaim in gone

Then iccaros said you need to download the latest Gaim source from here..(Where is here)?

You need to install the GNU TLS library development files. (What in the heck are those)?

What does compile gaim mean?

Then I get this error messege in my terminal: Couldn't find package ibgnutls10-dev

[email protected]:~$ compile gaim

bash: compile: command not found

Whew!! I was having a good time until this happend. and it's kinda hard to follow along when you get two different sets of instructions from two different people and the techniques are different. Like I said, I do better when I can read it step by step. (Makes better sense to me that way). That little Gaim icon is still there in my panel so apparently he didn't go anyplace because the removal didn't work:

[email protected]:~$ sudo apt-get remove gaim

Password:

Reading package lists... Done

Building dependency tree... Done

The following packages will be REMOVED:

gaim ubuntu-desktop

0 upgraded, 0 newly installed, 2 to remove and 0 not upgraded.

Need to get 0B of archives.

After unpacking 2236kB disk space will be freed.

Do you want to continue [Y/n]? Y

(Reading database ... 72558 files and directories currently installed.)

Removing ubuntu-desktop ...

Removing gaim ...

[email protected]:~$ sudo apt-get install libgnutls10-dev

Reading package lists... Done

Building dependency tree... Done

The following extra packages will be installed:

libgcrypt7 libgcrypt7-dev libgnutls10 libgpg-error-dev libopencdk8-dev

libtasn1-2-dev

Suggested packages:

gnutls-bin

The following NEW packages will be installed:

libgcrypt7 libgcrypt7-dev libgnutls10 libgnutls10-dev libgpg-error-dev

libopencdk8-dev libtasn1-2-dev

0 upgraded, 7 newly installed, 0 to remove and 0 not upgraded.

Need to get 1661kB of archives.

After unpacking 4301kB of additional disk space will be used.

Do you want to continue [Y/n]? Y

Get:1 http://security.ubuntu.com breezy-security/main libtasn1-2-dev 0.2.10-4ubuntu0.1 [182kB]

Get:2 http://archive.ubuntu.com breezy/universe libgcrypt7 1.1.90-9ubuntu1 [330kB]

Get:3 http://archive.ubuntu.com breezy/main libgpg-error-dev 1.0-1 [29.1kB]

Get:4 http://archive.ubuntu.com breezy/universe libgcrypt7-dev 1.1.90-9ubuntu1 [417kB]

Get:5 http://archive.ubuntu.com breezy/universe libgnutls10 1.0.4-8ubuntu1 [274kB]

Get:6 http://archive.ubuntu.com breezy/main libopencdk8-dev 0.5.5-10 [102kB]

Get:7 http://archive.ubuntu.com breezy/universe libgnutls10-dev 1.0.4-8ubuntu1 [328kB]

Fetched 1661kB in 3s (511kB/s)

debconf: unable to initialize frontend: Dialog

debconf: (Dialog frontend requires a screen at least 13 lines tall and 31 columns wide.)

debconf: falling back to frontend: Readline

Preconfiguring packages ...

Selecting previously deselected package libgcrypt7.

(Reading database ... 72522 files and directories currently installed.)

Unpacking libgcrypt7 (from .../libgcrypt7_1.1.90-9ubuntu1_i386.deb) ...

Selecting previously deselected package libgpg-error-dev.

Unpacking libgpg-error-dev (from .../libgpg-error-dev_1.0-1_i386.deb) ...

Selecting previously deselected package libgcrypt7-dev.

Unpacking libgcrypt7-dev (from .../libgcrypt7-dev_1.1.90-9ubuntu1_i386.deb) ...

Selecting previously deselected package libgnutls10.

Unpacking libgnutls10 (from .../libgnutls10_1.0.4-8ubuntu1_i386.deb) ...

Selecting previously deselected package libtasn1-2-dev.

Unpacking libtasn1-2-dev (from .../libtasn1-2-dev_0.2.10-4ubuntu0.1_i386.deb) ...

Selecting previously deselected package libopencdk8-dev.

Unpacking libopencdk8-dev (from .../libopencdk8-dev_0.5.5-10_i386.deb) ...

Selecting previously deselected package libgnutls10-dev.

Unpacking libgnutls10-dev (from .../libgnutls10-dev_1.0.4-8ubuntu1_i386.deb) ...Setting up libgcrypt7 (1.1.90-9ubuntu1) ...

Setting up libgpg-error-dev (1.0-1) ...

Setting up libgcrypt7-dev (1.1.90-9ubuntu1) ...

Setting up libgnutls10 (1.0.4-8ubuntu1) ...

Setting up libtasn1-2-dev (0.2.10-4ubuntu0.1) ...

Setting up libopencdk8-dev (0.5.5-10) ...

Setting up libgnutls10-dev (1.0.4-8ubuntu1) ...

[email protected]:~$ ./configure -enable-gnutls=yes

bash: ./configure: No such file or directory

[email protected]:~$ sudo make

make: *** No targets specified and no makefile found. Stop.

[email protected]:~$ sudo make install

make: *** No rule to make target `install'. Stop.

[email protected]:~$ sudo apt-get install ibgnutls10-dev

Reading package lists... Done

Building dependency tree... Done

E: Couldn't find package ibgnutls10-dev

[email protected]:~$ compile gaim

bash: compile: command not found

I'm just trying to get it right. So I'm a trooper and hangin' in there.

Edited by Mychal007

Share this post


Link to post
Share on other sites

you must have misspelled the name of the library, you need to do

sudo apt-get install libgnutls10-dev

the source iccaros was referring to is the file you downloaded using this command

wget http://easynews.dl.sourceforge.net/sourceforge/gaim/gaim-2.0.0beta2.tar.bz2

the command above downloaded the file called gaim-2.0.0beta2.tar.bz2 to the directory you were currently in. This file is called a tar file, it is like a zip file. next you need to untar(unzip) your gaim source code file.

tar -xjf gaim-2.0.0beta2.tar.bz2

now that the tarfile is untarred(unzipped), you can change into this directory. YOU NEED TO BE IN THE GAIM DIRECTROY TO COMPILE IT: that includes the commands configure, make, and make install.

cd gaim-2.0.0beta2
./configure --prefix=/opt --enable-gnutls=yes
make
sudo make install

using the option above --prefix=/opt will install gaim in the /opt direcrory. I think it is best to install your homebrewed programs in a different place then apt uses

Share this post


Link to post
Share on other sites

I don't know what in the world happend but I can't even get to GAIM anymore. I shut down my system after following the so many different directions I went to applications > Internet > Gaim Internet Messenger. And once I clicked on it I got this messege: Cannot launch entry

Details: Failed to execute child process "gaim" (No such file or directory) (What's a child process) and what did I do wrong here?

Man oh man this is so confusing right now. I really do need help here. I know I might need to start all over again but I'd rather do that as opposed to not having it working at all. And if it's not asking too much, could one person just walk me through this?.:

Oh boy!!

Edited by Mychal007

Share this post


Link to post
Share on other sites

you probably have it installed. depending on the ./configure option you used, you just need to tell gnome where gaim is located. did you use the option

prefix=/opt ?

Share this post


Link to post
Share on other sites

Yep.. and it didn't work.. Tell ya what. can you just tell me how to get it back to it's original state and I won't worry about it anymore. This is really becoming a real pain to me. I don't know anything about options, configuring or anything. That's why I'm asking questions here so that I can learn it. I'll just keep it the way it was once I get it back. I don't know what to do when it says Cannot launch entry

Details: Failed to execute child process "gaim" (No such file or directory). Please please please, just tell me how to get back to where it once was and I won't have to deal with it anymore.

Edited by Mychal007

Share this post


Link to post
Share on other sites

do the following, if you get any error messages about broken packages let me know.

sudo apt-get install ubuntu-desktop

after that has run, providing there are no errors, then close the terminal and start synaptic System>Administration>Synaptic package manager.

then do a search for gaim. install gaim and gaim_data make sure they are version 1.5

As stated before, Ubuntu runs into Dependency hell with this gaim beta version when installing. Thats why I recommended not installing it. Even in that thread that Naruku pointed out there were a lot of people running into the problem like you just had.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now