Sponsored By

Sign in to follow this  
Dragon

Bash Commands For Permissions

Recommended Posts

ok, I got a file I need to get rid of, it is currently set at Read only and because of it I can't delete it, even in Root, so my question is how do I change the permission so I can delete it?

Current setting are

drwxr-xr-r

everytime I try to remove it I get permission denied Read Only. It' s not a system file so I know I should be able to delete it.

Share this post


Link to post
Share on other sites
ok, I got a file I need to get rid of, it is currently set at Read only and because of it I can't delete it, even in Root, so my question is how do I change the permission so I can delete it?

Current setting are

drwxr-xr-r

everytime I try to remove it I get permission denied Read Only. It' s not a system file so I know I should be able to delete it.

You could try logging on as root, then as root right click the file, choose properties, then click on permissions, change the permissions on the file so you can delete it.

Share this post


Link to post
Share on other sites

ok, I got a file I need to get rid of, it is currently set at Read only and because of it I can't delete it, even in Root, so my question is how do I change the permission so I can delete it?

Current setting are

drwxr-xr-r

everytime I try to remove it I get permission denied Read Only. It' s not a system file so I know I should be able to delete it.

You could try logging on as root, then as root right click the file, choose properties, then click on permissions, change the permissions on the file so you can delete it.

tried that it didn't work, but I got rid of it, luckily my son wanted to play his games on Windows, so when I rebooted I was able to delete it go figure

Share this post


Link to post
Share on other sites

If you ever have this problem again, as root type chmod u=rw filename, that'll give user read and write. You can also you chown, to change the owner of the file.

Share this post


Link to post
Share on other sites

ok, I got a file I need to get rid of, it is currently set at Read only and because of it I can't delete it, even in Root, so my question is how do I change the permission so I can delete it?

Current setting are

drwxr-xr-r

everytime I try to remove it I get permission denied Read Only. It' s not a system file so I know I should be able to delete it.

You could try logging on as root, then as root right click the file, choose properties, then click on permissions, change the permissions on the file so you can delete it.

tried that it didn't work, but I got rid of it, luckily my son wanted to play his games on Windows, so when I rebooted I was able to delete it go figure

Good to hear you were able to get rid of it:-)

Share this post


Link to post
Share on other sites

For future reference: deleting a file requires write permission for the directory containing the file. When you create or delete a file you're (logically) editing the directory.

Edited by jcl

Share this post


Link to post
Share on other sites
For future reference: deleting a file requires write permission for the directory containing the file. When you create or delete a file you're (logically) editing the directory.

write permission was given to the directory, it was trying to lock it as part of the operating system, which has to be loaded at boot time. Now when I shut down DSL, I get an error that xxxxx files media is missing. go figure. I'm looking further into this.

Share this post


Link to post
Share on other sites
write permission was given to the directory, it was trying to lock it as part of the operating system, which has to be loaded at boot time.

Curious. It sounds like the immutable attribute (see chattr(1)) was set on the file for some reason.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this