Sign in to follow this  
Dragon

Can't Make My Initrd

Recommended Posts

ok, I have the Kernel built and the modules built, but when I go to use this command

mkinitrd /boot/initrd-2.6.16.img 2.6.16

I keep getting this bash comment

bash: mkinitrd: command not found

now I know I have mkinitrd on my system, I did a search for it and found it in /etc so I tried it using the full path to it and still got the command not found message.

What should I do now?

Share this post


Link to post
Share on other sites

It should be in /usr/sbin, most likely it is mkinitrd.conf you found in /etc. What does

which mkinitrd

produce?

Also a ram disk isn't always needed, I never make one when I build a kernel. If all necessary modules (to boot) are compiled in try booting the kernel.

Edited by naraku9333

Share this post


Link to post
Share on other sites
It should be in /usr/sbin, most likely it is mkinitrd.conf you found in /etc. What does
which mkinitrd

produce?

Also a ram disk isn't always needed, I never make one when I build a kernel. If all necessary modules (to boot) are compiled in try booting the kernel.

the which mkinitrd command produces nothing.

Share this post


Link to post
Share on other sites

well now I did it, I missed a step when I built the kernel. time to start over again. If I have any questions I'll post it here.

Share this post


Link to post
Share on other sites

well now I'm totally miffed, I just got through compiling the kernel and modules, set up grub to find the kernel, and I get a file does not exist error from grub. I know it's pointing to the correct place, so I'm thinking that I'm going to ditch Ubuntu until I get a new HDD for my linux installs. after I did the compilation and what not I know have approximately 1.5gig of HDD avialable and I dont' remember what all I installed to put this thing together.

since I have such a small HDD, I have decided to go with DSL. It's Debian based, so I am familiar with the system. The only thing I don't particularly care for is that uses KDE instead of Gnome.

Share this post


Link to post
Share on other sites

Don't give up so quickly. I bet it is just something simple you missed. If you care to mess around post your menu.lst file. also what does the following show.

ls /boot

Edited by shanenin

Share this post


Link to post
Share on other sites

Can you list the steps you went through, your menu.lst, and /boot directory listing as Shane suggested.

Share this post


Link to post
Share on other sites

ok, so I went in and doublechecked my grub and found my error. Now when i go to start teh Kernel I get a Kernel panic here is the message i get:

[17179571.220000] Kernel panic- not syncing: vfs unable to mount root fs on unkown-block (0,0)[17179571.220000]

any ideas? first time I have ever gotten a Kernel panic so I'm not sure what I should do to resolve this.

Edited Later: I went to a irc chat room where they help newbies do the Kernel, one of the members there helped troubleshoot the issue, I'm recompiling my Kernel now and will let you know if I have access or not.

Share this post


Link to post
Share on other sites

Great news, it's working, plus I have use of my optical mouse, woohoo!!!! so not only did I learn something new, but I also fixed my mouse problem, and made a leaner Kernel

new drawback, I now do not have access to my windows file, settings are the same as they were before in /etc/fstab the only thing I can think of is it's due to a fail status on loading the module for reading Windows.

Share this post


Link to post
Share on other sites
Great news, it's working, plus I have use of my optical mouse, woohoo!!!! so not only did I learn something new, but I also fixed my mouse problem, and made a leaner Kernel

new drawback, I now do not have access to my windows file, settings are the same as they were before in /etc/fstab the only thing I can think of is it's due to a fail status on loading the module for reading Windows.

Congratulations, Dragon! You really stuck with it! The gurus here can probably help you tweak it, but, it sounds like you can do this on your own! :thumbsup:

Share this post


Link to post
Share on other sites

cool, I bet you are glad you stuck with it, feels good :-)

Just curious, what was the problem?

new drawback, I now do not have access to my windows file

you can easily check to see if you enabled ntfs support in your kernel. using this command it shows I have ntfs support set as a module

[email protected] ~ $ cat /usr/src/linux/.config | grep -i ntfs
CONFIG_NTFS_FS=m
# CONFIG_NTFS_DEBUG is not set
# CONFIG_NTFS_RW is not set

the mount command should autoload the module for you.

Edited by shanenin

Share this post


Link to post
Share on other sites

two problems actually,

1st, I didn't catch that I had it ext2 setup as the protocol instead of ext3 in kernel

2nd, I had the the root system route listed as a module, so it couldn't find the hdb root.

when I run the cat command this is what I get

[email protected]:~$ cat /src/linux-2.6.16/.config | grep -i ntfs
CONFIG_NTFS_FS=y
# CONFIG_NTFS_DEBUG is not set
# CONFIG_NTFS_RW is not set

I had to have it hardcoded into the Kernel otherwise I get a Kernel panick.

Share this post


Link to post
Share on other sites

from your config you can see ntfs is built into the kernel, so that is not a problem. To see why your ntfs(windows) partition is failing, do the following: try and mount your windows partition, then run the command dmesg. It may give you a clue to what is happening.

Share this post


Link to post
Share on other sites

it appears already mounted. What does this command show. if it is mounted it will tell you where

sudo mount | grep /dev/hda1

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this