Sign in to follow this  
Dragon

Help!

Recommended Posts

hopefully one of our many Linux gurus can help me out here.

I go to start Ubuntu, and it hangs at bootup while trying to contact the host for DHCP. I thought maybe my iptables were screwed up and I was ready to reinstall so I tried to do that, but then i get "cannot contact DHCP host".

with our new fiber optics setup there is no router or modem used, direct connection from computer to data port, which then connects to the firewall/router at the phone company. I contacted my ISP and they said that since I can hook up with Windows I should be able to hook up with Ubuntu. this all started about a week ago. Not sure what other information you may need. as is I have to play musical mouse with it anyway because it won't recognize my optical PS2 mouse, so I have to revert back to my standard PS2 mouse to work in it.

Any ideas would be helpful.

Thanks.

Share this post


Link to post
Share on other sites

ok, used one of my LiveCD from Ubuntu. no problems other then no Interent connection.

I did a demsg and of course got the nice long report of everything. I specifically looked for anything dealing with eth0 and this is what I found.

eth0: no IPv6 routers present

could it be that I need to disable IPv6 to get my internet connection back?

also I think I figured out how to fix my mouse problem. it is trying to make the mouse a generic mouse. I'll work on that later, first I need to get my internet connection back.

Like I said before no modem/router between my computer and the data port since we went with fiber optics. router and modem are handled at the local phone company who is the connection point to the ISP.

Share this post


Link to post
Share on other sites

Nice so dhcp is hosted at the isp. I dont have any access to technology like that here. Tell me how you go from a fiber connection to the ethernet port of your pc? Or is it a full blown fiber ethernet card?

Pierce

Share this post


Link to post
Share on other sites
Nice so dhcp is hosted at the isp. I dont have any access to technology like that here. Tell me how you go from a fiber connection to the ethernet port of your pc? Or is it a full blown fiber ethernet card?

Pierce

just uses a standard cat5 cable from the computer to the dataport. we have a transformer box on the back of the house, changes the fiber over to standard phone line wire.

Share this post


Link to post
Share on other sites

if your live ubuntu cd is not working also, wouldn't that mean the change must be your ISP? Has your dhcp worked since they upgraded to fiber optics?

Share this post


Link to post
Share on other sites
if your live ubuntu cd is not working also, wouldn't that mean the change must be your ISP?

I asked them about that, nothing changed on the ISP end.

Has your dhcp worked since they upgraded to fiber optics?

yes, it just stopped working about a week ago, been on the fiber optics for about 4 months now.

Edited by Dragon

Share this post


Link to post
Share on other sites

sounds like a rough one, Dragon

All I could find on any ubuntu/dhcp problems lead to something wrong in /etc/network/interfaces

The only thing I can suggest is check the interfaces file for "auto eth0"

Share this post


Link to post
Share on other sites

I contacted the local phone company, they are my go between to the ISP. come to find out they had a 40 port blade blow last week. after it was replace not all configurations were reset, so they are working on it. they figure I should be back to what I was before by the end of next week.

Share this post


Link to post
Share on other sites
come to find out they had a 40 port blade blow

Good to hear it's not something on your end, sucks to have tp wait for them to fix it though. <_<

Could you or someone else define what I quoted? :blink:

Share this post


Link to post
Share on other sites
I contacted the local phone company, they are my go between to the ISP. come to find out they had a 40 port blade blow last week. after it was replace not all configurations were reset, so they are working on it. they figure I should be back to what I was before by the end of next week.

if you have time do this..

open a Termianl as root (or sudo what ever ubuntu does)

and do tcpdump -v /dev/eth0

then open another teminal and do the dhcpd /dev/eth0

and post the output of the tcpdump...

I had this same problem, adn it turned out to be my MAC address. They did not have my MAC in there system.. I guessing that you are dual booting.. so that may not be so.. (I always put a router betwen me and the ISP now.. so they have my routers MAC.. and I server my own DHCP.. using Monowall (using this http://www.soekris.com/net4501.htm board)

hope this gives you some ideals..

Edited by iccaros

Share this post


Link to post
Share on other sites

I contacted the local phone company, they are my go between to the ISP. come to find out they had a 40 port blade blow last week. after it was replace not all configurations were reset, so they are working on it. they figure I should be back to what I was before by the end of next week.

if you have time do this..

open a Termianl as root (or sudo what ever ubuntu does)

and do tcpdump -v /dev/eth0

then open another teminal and do the dhcpd /dev/eth0

and post the output of the tcpdump...

I had this same problem, adn it turned out to be my MAC address. They did not have my MAC in there system.. I guessing that you are dual booting.. so that may not be so.. (I always put a router betwen me and the ISP now.. so they have my routers MAC.. and I server my own DHCP.. using Monowall (using this http://www.soekris.com/net4501.htm board)

hope this gives you some ideals..

thanks Iccaros,

I would do that, but the problem is I can't even access the desktop or recovery mode since it won't configure the network settings. any suggestions on how to overcome that?

Share this post


Link to post
Share on other sites

I contacted the local phone company, they are my go between to the ISP. come to find out they had a 40 port blade blow last week. after it was replace not all configurations were reset, so they are working on it. they figure I should be back to what I was before by the end of next week.

if you have time do this..

open a Termianl as root (or sudo what ever ubuntu does)

and do tcpdump -v /dev/eth0

then open another teminal and do the dhcpd /dev/eth0

and post the output of the tcpdump...

I had this same problem, adn it turned out to be my MAC address. They did not have my MAC in there system.. I guessing that you are dual booting.. so that may not be so.. (I always put a router betwen me and the ISP now.. so they have my routers MAC.. and I server my own DHCP.. using Monowall (using this http://www.soekris.com/net4501.htm board)

hope this gives you some ideals..

thanks Iccaros,

I would do that, but the problem is I can't even access the desktop or recovery mode since it won't configure the network settings. any suggestions on how to overcome that?

There are a couple of ways, the easiest would be interactive mode durring init (Im not sure if Ubuntu supports it by default) you would see press I for interactive boot as init starts if it is enabled and not start the network (you will be asked whether to start each service). The next way I would do it is boot single user mode and disable your network interface init script. The last thing that comes to mind is a chroot (boot live cd, su to root, chroot <path to root> /bin/bash, and disable network.

Share this post


Link to post
Share on other sites

I contacted the local phone company, they are my go between to the ISP. come to find out they had a 40 port blade blow last week. after it was replace not all configurations were reset, so they are working on it. they figure I should be back to what I was before by the end of next week.

if you have time do this..

open a Termianl as root (or sudo what ever ubuntu does)

and do tcpdump -v /dev/eth0

then open another teminal and do the dhcpd /dev/eth0

and post the output of the tcpdump...

I had this same problem, adn it turned out to be my MAC address. They did not have my MAC in there system.. I guessing that you are dual booting.. so that may not be so.. (I always put a router betwen me and the ISP now.. so they have my routers MAC.. and I server my own DHCP.. using Monowall (using this http://www.soekris.com/net4501.htm board)

hope this gives you some ideals..

thanks Iccaros,

I would do that, but the problem is I can't even access the desktop or recovery mode since it won't configure the network settings. any suggestions on how to overcome that?

There are a couple of ways, the easiest would be interactive mode durring init (Im not sure if Ubuntu supports it by default) you would see press I for interactive boot as init starts if it is enabled and not start the network (you will be asked whether to start each service). The next way I would do it is boot single user mode and disable your network interface init script. The last thing that comes to mind is a chroot (boot live cd, su to root, chroot <path to root> /bin/bash, and disable network.

thanks naraku9333,

I'll try that this evening or tomorrow

Share this post


Link to post
Share on other sites
ae you still able to add a router to your setup? would letting the router do dhcp solve the problem?

Not if the dhcp problem is with the telco router, a home router will still need to recieve its IP through dhcp (unless specifically configured as static).

Share this post


Link to post
Share on other sites

but it should let Dragon boot.

also I did not see naraku show the steps to make grub boot single user..

see this red hat site..

http://www.redhat.com/docs/manuals/linux/R...ing-single.html

Share this post


Link to post
Share on other sites
but it should let Dragon boot.

also I did not see naraku show the steps to make grub boot single user..

see this red hat site..

http://www.redhat.com/docs/manuals/linux/R...ing-single.html

I forget to add the details sometimes ;P I agree, even with dhcpd failing he should be able to boot.

Share this post


Link to post
Share on other sites

ok, I will try the single user method this afternoon, wife is asleep right now after being up for 24 hours, a friend was having her baby and the wife was the coach.

Anyway, I tried to do the chroot option since interactive mode was not available to me, at least that I could see. couldn't make the livecd "see" hdb or hda. so that was unable to be done.

I talked to the telephone co. again yesterday, they put a sniffer on my line. but they didn't see my MAC address send the request for dhcp to assign the IP. the problem is that they couldn't see it when Windows was running either. So they are being proactive towards a resolution. I would just like to make sure that the problem isn't on my end. Especially since this started at the same time their blade switch crashed at the office.

but it should let Dragon boot.

also I did not see naraku show the steps to make grub boot single user..

see this red hat site..

http://www.redhat.com/docs/manuals/linux/R...ing-single.html

does it make a difference that Ubuntu is Debian based?

Not if the dhcp problem is with the telco router, a home router will still need to recieve its IP through dhcp (unless specifically configured as static).

The thing that is odd, obviously, is that I can boot to Windows on this machine. I dual boot, Windows one HDD and Linux on another HDD. I don't trust partioning. So I can connect with Windows but not with Linux on the same machine. I hope this doesn't make it harder to figure out what's going on.

Share this post


Link to post
Share on other sites

ae you still able to add a router to your setup? would letting the router do dhcp solve the problem?

Not if the dhcp problem is with the telco router, a home router will still need to recieve its IP through dhcp (unless specifically configured as static).

my thought was windows was able to get an address using dhcp, so the router may also be able to get one.

Share this post


Link to post
Share on other sites

ae you still able to add a router to your setup? would letting the router do dhcp solve the problem?

Not if the dhcp problem is with the telco router, a home router will still need to recieve its IP through dhcp (unless specifically configured as static).

my thought was windows was able to get an address using dhcp, so the router may also be able to get one.

the only problem is right now I don't have the money for a new router. won't have it until the middle of the month at the earliest, lots of bills due right now.

Share this post


Link to post
Share on other sites

ok, I did the single user mode. here is what is happening. sorry I have to type this out since I can't grab a screenshot or logfile.

splash screen shows up, I get the booting Linux Kernel.

loads modules,

gets all the way to configuring newtork interfaces and hangs right there, up until the system puts itself into a state of hibernation some how, about 30 minutes later. Now it's at this point that my IP address from Windows is released. So I am presuming it is at this point that ubuntu is trying to obtain the new IP from DHCP.

thats as far as I can get when it comes to booting Ubuntu.

If you want I can try and get the dmesg from the livecd startup so you can have a little look at whats going on. but I don't think it will be as accurate as one from the installed version, since it goes to the desktop without allowing me access to the net.

If I could get instructions on making the liveCD mount the linux hdd, I might be able to pull a syslog from it.

Share this post


Link to post
Share on other sites

to give more details to what naraku9333 said. you should be able to disable your network interface by using a live cd

boot your live cd, then open a root terminal(if that is an option with ubuntu)

then run these commands

mkdir /mnt/fix
mount /dev/hdb* /mnt/fix
mount -t proc proc /mnt/fix/proc
chroot /mnt/fix /bin/bash

/dev/hdb* needs to be changed to the correct partition your main ubuntu "/" partition. probably devhdb1, dev/hdb2, or dev/hdb3

now you have changed the "/" directory, so in essence your are running your harddrive install of ubunutu. Now you just need to turn off the networking service. I think this works for debian(ubuntu)

update-rc.d -f  networking remove

now just exit

and reboot

edit added later//

if I could get instructions on making the liveCD mount the linux hdd, I might be able to pull a syslog from it.

the first part above shows you how to mount your partition.

to find out what partition you "/" is on do the command

/sbin/fdisk -l /dev/hdb

you main "/" parition will be the largest. this is the one you need to mount in the above instructions

Edited by shanenin

Share this post


Link to post
Share on other sites

thanks I will try that later tonight. I'm a little busy at the moment working on someones website ;)

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this