Sign in to follow this  
baker7

Windows 10 and IIS 10: cant see website from outside

Recommended Posts

Good Morning Team:

I have been using Windows 10 Pro 64 bit for about 3-4 months.  I have also installed Internet Information Services Manager (IIS) Version 10.0.  I will tell you a little story:

Many of you know from my postings from about 2011 forward that I was working on my Linux Server (Debian 5.0 - Lenny) for a LONG while, setting up web and shell based services.  In July of 2013, the server went down for the last time, and has not been connected to the Internet or the Intranet since.  I have renewed BBUS's Domain for 2016, and would like to continue to serve a page to people.  This time, would like to run it off of this PC (BRIAN-PC).  Why you ask?  This is because someone broke into our offices and removed all computers that were in the basement of this location.  This really made me MAD, as I had put so much time into this machine, and it actually WORKED well.

Now, I want to move forward and try to serve a page.  I am really at a crossroads here, because when I installed IIS, I configured it as I believe it should be, and when the server is ON and running, if I am sitting in front of BRIAN-PC, I can go to http://buddy-baker.us, or http://www.buddy-baker.us I can get the site to pop up, because it seems to resolve to my PC.  I have opened ports in testing phases, Port 80, and Port 9000.  Doing this brings up the site on the internal IP, as long is it is bound to the site. 

However, If I go to my roommate's Apartment across the hall, I go to http://buddy-baker.us or http://www.buddy-baker.us, or https://buddy-baker,us or https://www.buddy-baker.us I get nothing but a "Waiting for Response from buddy-baker.us" and then it just goes to an "Oops..." Page. 

It seems that when I PING buddy-baker.us I get 4 rounds from 75.133.xxx.15.

So there are other things I have noticed as well.

1.  I have opened port 80 for 192.168.0.10 - I also opened port 9000 -   These ports are forwarded to the external IP of buddy-baker.us  -  They seem to respond OK

2.  The "oops Page" is telling me it cannot display the webpage when I do further investigation, it shows a time out

3.  Even though I have opened port 80 and port 9000, if I use a port scanning tool, it shows ALL ports closed.

4.  for XBOX ONE - One of the ports it needs for operation is port 80 - I KNOW from past experience, that this is because of the use of MS Edge.  Since I don't use MS Edge on the xbox, and because you cannot have the same port open for 2 different IP addresses at the same time, I REMOVED port 80 from the XBOX ONE's IP Addresses - It seems that there is a plethora of ports that it uses.

5.  I added an INBOUND Rule to ALLOW Ports 80 and 9000 through the Windows Firewall.

6.  SSL (https://) is NOT available right now, because it has not been installed

7.  I have tools called Remote Access Manager, and File Server Resource Manager - I also have placed the Event Viewer, the Performance Monitor, and the Component Services on the Desktop and pinned IIS Manager to the Taskbar.

8.  I have also tried to figure out how to fix this problem  - There is Little to NONE documentation for IIS 10.0, so  most of what I have read concerns older versions (7.0, 7.5, 8.0) and these are different in some ways.  I have even tried to go to YouTube and while it has the instructions for setting UP IIS, it does not seem to offer any configuration help - and Yes, I have googled my heart out on this,

Can someone give me a hand here??  I have Screenshots of the Router/modem as well, so you can see it.

Thanks Team,

Brian

 

 

 

 

 

 

 

 

 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this