Sponsored By

Sign in to follow this  
Chappy

Repair Or Restore Cd Autorun Feature

Recommended Posts

Hi Everyone!

This is an issue that has affected many folks in the past, and we never really had a good handle on it for a fix. I just recently had this problem popup and I remembered how many times I saw this come up on TTV boards and a few times at G4, so after I found and researched the fixes for it on my VM's, I decided to post it here for others to benefit from.

There are a few things here that may be causing this, depending on what disabled it in the first place. Some CD burning programs disable AutoRun, one version of Nero did this but did not have an "Enable" button to re-enable it once more. With Office 2000 installed on XP, Autorun is disabled, using Virtual Machine software (not JavaVM) prompts to disable Autorun and doesn't re-enable it, and Norton System Works 2004 seems to also disable AutoRun tho I have not found other confirmation of this yet. There are still other programs and many other things that may also disable autorun, so hopefully this tip will help get it going for you again.

These tips require editing the registry, so if you don't know how to do this or need a refresher, please read my tutorial on How to Edit the Windows Registry for instructions.

The very first one to try is, of course the easiest, but also the most common repair. Open Regedit and navigate to this key:

HKEY_LOCAL_MACHINE\system\currentcontrolset\services\cdrom, click CDROM in the left hand pane to highlight it.

If the AutoRun DWord value in the right hand pane is set to 0, its disabled.

With the CDROM key highlighted in the left pane, dbl-clk AutoRun on the right to open the value editor, and change the value to 1 (enabled)

If that doesn't fix it, we need to look at other areas in regedit for the problem. With My Computer highlighted in the left pane, click Edit in top menu bar and then Find, type in NoDriveTypeAutorun in the find box and hit FIND NEXT.

Change the value for every instance of this key to 0x00000091. After changing the first one, hit F3 to find the next instance, and continue this until it tells you its finished searching.

For W2k and NT, the default value is 0x00000095.

Another key to look at is anything with AutorunAlwaysDisable, search for all instances of this phrase and check to see if your CD Drive type is listed in there. I'm not exactly sure why these drive makes/models are listed here and I'm researching it to find out why these drives have to have AutoRun disabled. Most likely anyone with one of these drives has the AutoRun disabled during the drive's software installation.

I hope this will solve this issue for anyone who's having this now, or will help in the future if this happens to you.

Share this post


Link to post
Share on other sites
Sign in to follow this