Sponsored By

Sign in to follow this  
bearskin

Hosts File

Recommended Posts

ok guys..here's the problem. I'm using win me and my hosts file is in the C:\windows directory. now that's where it's supposed to be. I loaded all the sites that should be blocked but it won't block these sites in IE. I have no problem with firefox because I use adblock but the wife insists on using IE. should I slap her? (did I say that)....I even try to block them with spybot S/D. sooooooo...can anyone tell me why IE won't block these sites?

Share this post


Link to post
Share on other sites

Hmmm, all I can think of is that the entries are not written in correctly or they are in the trusted zone as well.

Can you provide a screenshot of your hosts file? The top section should do as long as it has some of the entries that you've put in showing.

Maybe IE is looking for it in another location as well..??

Try putting a copy of the file in your C:\WINDOWS\SYSTEM32\DRIVERS\ETC folder as well, if this exists in ME.

Share this post


Link to post
Share on other sites

Here you go chappy....there's a lot more. I just show these.

127.0.0.1 localhost

127.0.0.1 www.doubleclick.net

127.0.0.1 ad.doubleclick.net #remove this for atomfilms problems

127.0.0.1 ad.preferences.com

127.0.0.1 ads.doubleclick.com

127.0.0.1 ads.infospace.com

127.0.0.1 ads.msn.com

127.0.0.1 ads.switchboard.com

127.0.0.1 doubleclick.net

127.0.0.1 ads.doubleclick.net

127.0.0.1 ad2.doubleclick.net

127.0.0.1 ad3.doubleclick.net

127.0.0.1 ad4.doubleclick.net

127.0.0.1 ad5.doubleclick.net

127.0.0.1 ad6.doubleclick.net

127.0.0.1 ad7.doubleclick.net

127.0.0.1 ad8.doubleclick.net

127.0.0.1 ad9.doubleclick.net

127.0.0.1 ad.ch.doubleclick.net

127.0.0.1 ad.linkexchange.com

127.0.0.1 ads.enliven.com

Share this post


Link to post
Share on other sites

Just asking, what kind of sites are you trying to block? Bad, malware-type sites, or parental lock-type sites? If it is the former, perhaps IE-SPYAD would be a good choice.... :D

Share this post


Link to post
Share on other sites

thanks chappy. Iput the host file in C:\windows\system32\drivers. I think that did the trick. who would've thunk that IE would look at my drivers. LOL

oh..murtu52..I have IE-SPYAD and that blocks out all my good sites...hahaha

Share this post


Link to post
Share on other sites
thanks chappy.  Iput the host file in C:\windows\system32\drivers.  I think that did the trick. who would've thunk that IE would look at my drivers.  LOL

oh..murtu52..I have IE-SPYAD and that blocks out all my good sites...hahaha

<{POST_SNAPBACK}>

Oh, I see :lol::lol::lol:

Share this post


Link to post
Share on other sites

Hi Bearskin

Did you copy the hosts file and put a copy into the C:\windows\system32\drivers\etc file, or did you move the original into the new location? I would'nt move the original just yet so make a copy of it and put the copy into the new location.

I noticed that you said you put it into the "drivers" folder, there should be a folder in the drivers folder called "etc" and that is where the hosts file copy should go.

The hosts entries look ok, they are mapping back to your loopback IP which means that they should not be accessible.

Share this post


Link to post
Share on other sites
Hi Bearskin

Did you copy the hosts file and put a copy into the C:\windows\system32\drivers\etc file, or did you move the original into the new location? I would'nt move the original just yet so make a copy of it and put the copy into the new location.

I noticed that you said you put it into the "drivers" folder, there should be a folder in the drivers folder called "etc" and that is where the hosts file copy should go.

The hosts entries look ok, they are mapping back to your loopback IP which means that they should not be accessible.

<{POST_SNAPBACK}>

Chappy I put a copy in the C:\windows\system32\drivers....I left the original in the C:\windows directory. I don't have any folders in C:\windows\system32\ drivers...I only have files. it seems to work...thanks

Share this post


Link to post
Share on other sites
ok guys..here's the problem.  I'm using win me and my hosts file is in the C:\windows directory.  now that's where it's supposed to be.  I loaded all the sites that should be blocked but it won't block these sites in IE.  I have no problem with firefox because I use adblock but the wife insists on using IE.  should I slap her? (did I say that)....I even try to block them with spybot S/D.  sooooooo...can anyone tell me why IE won't block these sites?

<{POST_SNAPBACK}>

yo bearskin yes give her one.

that will teach her good

ha ha ha

marty

Share this post


Link to post
Share on other sites

well it seems I was wrong again. I still can't get rid of the ads. they went away for a while, now they're back. I even put the sites in my restricted zone in internet options and it didn't do any good. I have no problem blocking in firefox but can't block them in IE. oh well..my wife will just have to put up with them and I'll use firefox...

Marty....as for your question....sorry, no answer.

Share this post


Link to post
Share on other sites
well it seems I was wrong again.  I still can't get rid of the ads.  they went away for a while, now they're back.  I even put the sites in my restricted zone in internet options and it didn't  do any good.  I have no problem blocking in firefox but can't block them in IE.  oh well..my wife will just have to put up with them and I'll use firefox...

Marty....as for your question....sorry, no answer.

<{POST_SNAPBACK}>

The Win98/ME host file belongs in C:\Windows. Did you by chance use the host.sam file? This file is a sample not the actual host file that has to be created. The easiest way to create the host file is to open HijackThis and click on the Open the Misc Tools section button, then Open hosts file manager. If I remeber right you now click the Open in Notepad button and it should ask if you wish to create it. It is in this file that you place the sites you wish to block. Remember to leave a couple of spaces between the 127.0.0.1 and the URL or IP of the site you want blocked.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this