Sponsored By

Sign in to follow this  
JDoors

New external drive, AutoPlay insists on a dialog box on wakeup

Recommended Posts

Windows 7 64-bit

I have one of those external USB-powered drives mainly meant to be used for backups (which is what I'm using it for).

When my computer goes to "sleep" then wakes, the AutoPlay dialog box opens asking me what I want to do with that drive. I don't want to "do" anything, backups are set to automatic.

The AutoPlay settings have tons of options for every kind of media you can imagine, but no particular option to turn off the dialog box for hard drives. Plug in a CD? Tons of options. Music on a drive? Options. Blu-Ray disk? No options (I don't have a BR player -- Ha! Gotcha!).

So is there a way to disable that dialog box for a single hard drive? I plug others in (generally thumb-drives) and I often DO want that dialog box for those, so if there's a way to turn it off completely, that's not really ideal. Just the one drive. :huh:

Edited by JDoors

Share this post


Link to post
Share on other sites

Does it have a Do Nothing option on that Dialog box and a checkbox to Always do this for this device?

Share this post


Link to post
Share on other sites

The options dialog box breaks things down more along the lines of what is found ON the disk. There is, as far as I can find, no way to specify, "Don't do anything with THIS PARTICULAR disk." Here are the options I have:

Audio CD <options>

Enhanced Audio CD <options>

DVD Movie <options>

Enhanced DVD Movie <options>

Software and Games <options>

Pictures <options>

Video Files <options>

Audio Files <options>

Blank CD <options>

Blank DVD <options>

Blank BD <options>

Mixed Content <options>

Blu-ray Disk Movie <options>

DVD-Audio <options>

Video CD <options>

"Mixed Content" seems to be one possibility, but then ANY disk I plug in that has mixed content won't ask me what I want to do with that disk. Is that my only option? Is there something I'm missing?

Share this post


Link to post
Share on other sites

Those instructions don't work for me, I don't get the "Programs" search results. If I try the "Run" command it replies that program is not found.

Not sure that's what I need as it appears to turn off ALL disks of one kind, I'm wonderin' if I can turn off Autoplay just for this one drive that I want to leave plugged in.

Share this post


Link to post
Share on other sites

Are you running Home Premium? If so gpedit is not available.

Try this.

Turn off AutoPlay for only one type of media

Open AutoPlay by clicking the Start button , and then clicking Control Panel. In the search box, type autoplay, and then click AutoPlay.

In the list next to each type of media that you don't want to be asked about, click Take no action, and then click Save.

Share this post


Link to post
Share on other sites

To make matters more confusing, last night I left a thumb drive plugged in and went to bed. Today when I "woke" the computer that hard drive "autoplayed" and asked what I wanted to do ... but the thumbdrive DID NOT trigger an alert.

(When I hot-plug the thumbdrive it does trigger an alert, which I'd like it to continue doing, hence my dilemma.)

Why is that?

Edited by JDoors

Share this post


Link to post
Share on other sites

I was hopin' there's a setting to ignore autoplay on individual drives, if it doesn't exist or no one knows, then I'd prefer to "deal with" closing the autoplay dialog. It's only once a day. <_<

Share this post


Link to post
Share on other sites

their is a part in there about creating a reg entry to disable a drive by the letter. You may just be able to assign the drive a letter like "t", then disable autorun for drive "t"

Share this post


Link to post
Share on other sites

Sounds ideal, but I can't get that page to load even if I go there using a method other than your link. Huh. I have used Wiki for other things as recently as last night, so it's not Wiki. I'll work on it when I have more time. Again, sounds like what I'm lookin' for, thanks.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this