Sponsored By

Sign in to follow this  
Honda_Boy

Monitor resolution issue

Recommended Posts

My most recent foray into linux has left me with thankfully only one minor issue. I just installed 32-bit Ubuntu 9.10 onto an old computer and I can't get the nVidia X Server thing to save my resolution. I want it at 1280x960 but it keeps defaulting to 1024x768. I've tried both drivers Ubuntu offers me and I keep getting this error every time I try to save the resolution on both.

graphicsissue-1.jpg

It will happily change to the new resolution no problems. It just won't save and it goes right back 1024x768 every time you start it up.

Here's the specs:

AMD Athlon XP 2000+

VIA KT333 Chipset

768MB DDR 266 RAM

GeForce FX 5700 Ultra 256MB DDR2

Anybody have any idea how to fix? Wouldn't bother me to much to reinstall if you think that'll fix it. The disc I used probably wasn't the greatest.

Thanks for any help!

Share this post


Link to post
Share on other sites

First thing I'd do is log out, log back in, and check ~/.xsession-errors and the system logs (/var/log/Xorg.0.log -- really, everything under /var/log/) and see if X or the NVIDIA driver are complaining about anything.

If there's nothing in the log, you could flail around a bit. Three approaches come to mind. (You don't have to log out while you're doing any of this, but you do have log out and back in for the changes to take effect.)

First, you could move (not copy!) your xorg.conf somewhere safe (I usually just rename it xorg.conf.bak) and then run nvidia-xconfig as root to generate a fresh xorg.conf. If the new files works, you can copy anything not related to the display that looks important from the old xorg.conf to the new one.

Second, you could delete or comment out (by adding a # to the beginning of each line) everything related to display settings in xorg.conf and see if correct resolution is auto-detected. IME auto-detection works very well these days.

Third, you could try to force X to use the correct resolution. It's been years since I've done that but I think you could get away with editing the Device, Monitor, and Screen sections in xorg.conf like so

Section "Device"
Identifier "Device0"
Driver "nvidia"
EndSection

Section "Monitor"
Identifier "Monitor0"
EndSection

Section "Screen"
Identifier "Screen0"
Device "Device0"
Monitor "Monitor0"
DefaultDepth 24

Subsection "Display"
Depth 24
Modes "1280x960"
EndSubsection
EndSection

You might also have to edit to the Screen section to add

    Option "ModeValidation" "NoEdidModes"

or

    Option "UseEdid" "FALSE"

to order the NVIDIA driver to ignore the display when determining what modes are available.

Incidentally, if you aren't using multiple displays, you might want to add

    Option "DynamicTwinView" "FALSE"

to the Screen section to disable TwinView. When TwinView is enabled the driver lies about the screen refresh rate, which, as I recall, breaks vsync.

Share this post


Link to post
Share on other sites

I think for his error, he needs to run

gksudo <name of the nvidia settings tools> (then it can read and save to the xorg file)

Share this post


Link to post
Share on other sites

If the file was unreadable, I'd expect an open error or read error instead of a parse error. It sounds like it's corrupt.

Share this post


Link to post
Share on other sites

That is a Good point, I am just working on the point that you can not edit that file as a user and need elevated privilege. The ubuntu tool for monitor configuration asked for your password. The nvidia one is a standalone tool and does not check if you have privileges.. it is letting him change the settings, then it sets to monitor to the correct setting, it just will not let him save the settings (its creating a tmp xorg.conf in his folder and restarting the xserver.. I am assuming from his statement

It will happily change to the new resolution no problems. It just won't save and it goes right back 1024x768 every time you start it up.
)

its when he reboots he has to start over..

but now that I think back it does give a failed to read error when it is just permissions..

there are a few bug reports that lead me to believe that the nvidia-settings wants a specific layout of the xorg file and when not seeing that it has issues.. they recomend as you to:

mv or rm the xorg.conf file

sudo nvidia-xconfig

gksudo nvidia-settings

and just tell it to save the settings..

Share this post


Link to post
Share on other sites

I'm going to have to reinstall anyway. I think I somehow wound up with the UK version. Though I set everything to US, it seems that all the spelling corrections are for UK spellings of words and not US spellings such as giving me the red line for Color, Behavior, and Mom and suggesting I spell them Colour, Behaviour, and Mum. So I'll download a US version ISO, burn a new disc and reinstall it.

If the issue is still present (which I'm willing to bet it will be) then I'll give your fixes a try. But that'll have to wait till Saturday most likely. I keep this box at my parents' house and I'm heading back to my apartment in the morning.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this