Sponsored By

Sign in to follow this  
Timspo14

Dual Monitor Problem

Recommended Posts

I have my PC hooked up to both a monitor through the VGA port, and a TV through an adaptor that came with my Nvidia GeForce 6600. When I reboot my computer, I see the same display on both screens so I know everything works and is hooked up properly.

The problem is that as soon as the OS (windows 7) starts, the TV display goes blank. I have all the recent drivers installed, and have tried configuring it with both the control panel and the Nvidia configuration program. The computer recognizes that there are two displays connected, but when i click 'identify' only the monitor shows the number.

I recently had linux installed on this same computer and had the same problem where the displays would work until the OS was fully boot up. Anyone know what's up with this and why it's not working?

Share this post


Link to post
Share on other sites

Try going into the Windows Display settings (where you manage screen resolution and identify monitors) and checking the box "Extend the desktop onto this monitor". Also take a look at the "Setting Up Multiple Displays" wizard in the nVidia control panel.

Share this post


Link to post
Share on other sites

Hmm, still no luck. I've tried a few different drivers but none of them want to work.

Like I said, the computer detects that the TV is connected via S-Video, but the screen is just black. It works fine on boot, until the OS starts.

Share this post


Link to post
Share on other sites

Ok so I've done some research and determined that this is definitely a driver issue, not a hardware or even settings problem. For whatever reason, the most up-to-date drivers do not want to allow me to output on 2 displays.

So, until I can figure this out, does anyone know of an OS that WILL work with dual-monitors and an NVidia Card + adaptor? OpenSuse 11.1 didn't want to work either.

Share this post


Link to post
Share on other sites

It's not that it doesn't want to run dual monitor but it probably just doesn't like outputting to a TV via S-Video. I've had problems before with S-video and nVidia cards. I run dual monitors all the time on with my nVidia cards but I run 2 LCD's via DVI. I've had better luck with S-video out to TV's with ATI and strangely, Intel video chips. That's why I prefer nVidia for desktops and ATI for laptops. Then again you have an older card, and I didn't start using dual/triple monitors regularly until I had 7600GT.

Also what res are you trying to run at cause most older TV's will only run up to 1024x768 (though their actual resolution is lower). If you are trying to clone the display to the TV you might have trouble unless you set it to a lower res.

Edited by Honda_Boy

Share this post


Link to post
Share on other sites

I've tried resolutions anywhere from 800X600 to 1024*768. It doesn't really change anything.

What's funny is that as soon as I uninstall the drivers, dual display works just fine between the computer and TV. I kind of think I'm just going to have to find some drivers that actually work with the card instead of using the most up to date ones

I've used this setup years ago with Windows XP so I know it can do it, it just is being very fussy with the newer OSes and drivers.

I've heard ATIs work better for this sort of thing, but this is a secondary computer that I'm mainly just playing around with so if I can't get it to work my laptop can do this exact sort of thing just fine.

edit: funny, i just noticed we joined this site the exact same day almost 4 years ago. you have 100 times the posts i do though. haha

Edited by Timspo14

Share this post


Link to post
Share on other sites

In linux anyway you can use the tool nvidia-settings and twinview to do what you want.

nvidia-settings is a gui tool that lets you easily set up twinview. No need to hack the xorg.conf yourself

Hope that helps on that end :)

Oh and make sure you have the proprietary drivers installed

Edited by Sir_Siddy

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this