Sponsored By

Sign in to follow this  
bobgo2728

Hooking Mac Mini Into Surround Sound

Recommended Posts

OK I was looking at the back of my mac mini and was told that I could use a fiber optic or toslink audio on there to hook into my surround sound. But I noticed it was not 5.1 at all. I could not also adjust the audio either. What is the deal here. Is my mac mini able to do 5.1 out of the ports?

MacMini_2006_09.jpg

Share this post


Link to post
Share on other sites

Audio preferences are in system preferences / sound.

I use optical out on my imac and a quick look in the audio/midi setup utility it shows 5.1 and 7.1 in the speaker configuration. Of course they are not accessible because I don't have a 5.1 system. But I also think you would need a 5.1 quicktime plug in or some kind os AC-3 decoder.

Share this post


Link to post
Share on other sites

OK I am not seeing anything in Lep that shows any OS X audio stuff. my audio control panel is greyed out on the taskbar. I don't see anything in the sound control panel. it just says digital out and built in output. I don't see anything else.

Edited by Buddy Holly

Share this post


Link to post
Share on other sites

Well I'm not sure if your speakers are like mine (i have the logitech z-500) but with mine all the audio control is grayed out because the audio is sent raw to the speaker system and the speakers doing all the 5.1 surround. If on a pc where on the back you have all the colored ports I think there are like 5 or something this is because the audio is being processed (not sure if that's the correct word to use) on board and then sent out.

I think this is whats going on, I could be wrong this is only from what I picked up.

Share this post


Link to post
Share on other sites

ok the audio is being sent out raw? I would think there would be some way to change it over to PCM or what ever. It is going out via a toslink or optical into my 5.1 audio home receiver. It says it is getting a digital reception on the receiver. But I want the audio to be 5.1 all the time not 2 channel and then when I play DVD's it is 5.1.

Share this post


Link to post
Share on other sites
ok the audio is being sent out raw? I would think there would be some way to change it over to PCM or what ever. It is going out via a toslink or optical into my 5.1 audio home receiver. It says it is getting a digital reception on the receiver. But I want the audio to be 5.1 all the time not 2 channel and then when I play DVD's it is 5.1.

PCM is RAW...

Also you have to set up audio on most DVD's to do 5.1 as they revert to stereo for default.

also are you sending this audio to a TV then to a separate audio system.. if so under HDCP processing stereo is all you get.

Share this post


Link to post
Share on other sites
OK I am not seeing anything in Lep that shows any OS X audio stuff. my audio control panel is greyed out on the taskbar. I don't see anything in the sound control panel. it just says digital out and built in output. I don't see anything else.

Do a spotlight search for Audio Midi you will get the Audio Midi Setup utility. Check the properties for output, speaker configuration.

And Taskbar = Menubar, Control panel=System Preferences.

Share this post


Link to post
Share on other sites

OK I did that and in there I set it for Multi Channel. it says source digital out and only gave me two channels to work with. I am sending this audio out of my mac mini to my 5.1 A/V receiver that is using optical or toslink. So why no surround?

Do a spotlight search for Audio Midi you will get the Audio Midi Setup utility. Check the properties for output, speaker configuration.

And Taskbar = Menubar, Control panel=System Preferences.

Share this post


Link to post
Share on other sites

I don't know much about multi channel out I did have a M-Audio 7.1 card in my old G4 that came with 7.1 driver and a codec pack.

I think what you need is a quicktime plugin that can decode the type of 5.1 audio that your dvd use. Maybe the AC-3 plugin.

Share this post


Link to post
Share on other sites

I understand the frustration... but remember its not that they are not allowing... you must have a HDCP approved Codex to do 5.1 (or better) and that is a licencing fee. My Dell does not do 5.1 either with out a plugin the same as the apple. it says 5.1 on everything.. but does not put it out.. I blame the MPAA and RIAA for all of the copywrite protection.

but frustration noted and I believe Apple should have a help on their site that tells you how to do this.

Share this post


Link to post
Share on other sites

try a spotlight search of com.cod3r.a52codec.plist

Share this post


Link to post
Share on other sites

reading the comments found this..

I followed the steps and ran into the same problem finding the plist file in leopard. I looked around a little bit, and found that you dont need perian or to change the midi settings at all. In fact, you can turn on Dolby Digital passthrough and get that nice little red dolby digital light (if you have an onkyo amp) by going to the preferences while in the dvd player, it has to be stopped first, and under “disc setup” the audio options at the bottom allow you specify which output you want…and select whatever is appropriate.

Hope that helps anyone with leopard!

# Kyle Kolbe Says:

December 20th, 2007 at 8:33 am

In Leopard, I’ve settled on Mplayer (1.0rc2 latest svn build, you need X11 installed for it to work). You can set Mplayer’s prefs with a command line to passthrough AC3 and DTS signals from a Mac’s optical output. In Mplayer’s prefs-additional parameters add

“-ac hwac3,hwdts,”

I think, I have to double check. Only way I’ve been able to get true surround sound out of MKV files on the Macbook Pro.

# Andre Lorentsen Says:

December 31st, 2007 at 5:25 pm

Followed the steps and can confirm that this works perfectly under Leopard. The plist file is in your home library folder.

The tip from Kyle Kolbe also works for mplayer 1.0rc2.

Share this post


Link to post
Share on other sites

OK I am confused here. What are you trying to tell me here?

reading the comments found this..

I followed the steps and ran into the same problem finding the plist file in leopard. I looked around a little bit, and found that you dont need perian or to change the midi settings at all. In fact, you can turn on Dolby Digital passthrough and get that nice little red dolby digital light (if you have an onkyo amp) by going to the preferences while in the dvd player, it has to be stopped first, and under “disc setup” the audio options at the bottom allow you specify which output you want…and select whatever is appropriate.

Hope that helps anyone with leopard!

# Kyle Kolbe Says:

December 20th, 2007 at 8:33 am

In Leopard, I’ve settled on Mplayer (1.0rc2 latest svn build, you need X11 installed for it to work). You can set Mplayer’s prefs with a command line to passthrough AC3 and DTS signals from a Mac’s optical output. In Mplayer’s prefs-additional parameters add

“-ac hwac3,hwdts,”

I think, I have to double check. Only way I’ve been able to get true surround sound out of MKV files on the Macbook Pro.

# Andre Lorentsen Says:

December 31st, 2007 at 5:25 pm

Followed the steps and can confirm that this works perfectly under Leopard. The plist file is in your home library folder.

The tip from Kyle Kolbe also works for mplayer 1.0rc2.

Share this post


Link to post
Share on other sites

this was a comment on that page that showed that the file did not exists in Leopard. the went to the preferences of DVD player to set it.

Share this post


Link to post
Share on other sites

sure..

Share this post


Link to post
Share on other sites

I have to hook mine back up, but if you can set the settings in the dvd player I would assume you do not need the plug in.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this