Sign in to follow this  
jrbarker

Sxbios.dll Error For Sony Vaio Notebook

Recommended Posts

I'm sorry if this has been covered. I tried to search for this problem on the boards with no luck yet.

So recently I've been getting an error every time I start my machine. [sony Vaio notebook PCG-691L]

It says there is an error with SXBIOS.DLL and BSNTSBS.DLL.

And now I can only access the internet in safe mode. I can't download Windows updates at all in regular or safe mode. What should I do to correct this problem? It doesn't appear to be a virus. Maybe some kind of corrupt file.

Thank you so much for any help.

Windows XP Pro

V. 2002

Service Pack 3

Pentium M 1400mhz

1.39ghz 512 mb ram

Share this post


Link to post
Share on other sites

Problem with the sony Extended BIOS Dynamic Link Library being corrupt.

http://esupport.sony.com/perl/swu-download...=26&os_id=6

Needs to be reinstalled.

Darn that is the me link

will find XP

Closer

http://www.kb.sony.com/selfservice/microsi...%200%2084677843

Ah here we go

http://www.kb.sony.com/selfservice/microsi...%200%2084677994

Direct download

ftp://download.sony.com/US/pc/SOASSL-10133900-US.EXE

Alternative approach (not really recomended) is locate the files in question in

C/program files/common files/sony shared/SxBios

Rename them to

SXBIOS.OLD and BSNTSBS.OLD

restart and let windows file protection or whatever find the backup copies and replace them.

Share this post


Link to post
Share on other sites
It seemed to work. Thank you very much!

Which approach worked for you?

Please let us know so when someone comes googling for the solution they can find out what works

Share this post


Link to post
Share on other sites

Installing the below link that Pete_C provided fixed not only the sxbios issue but also enabled hotkey functionality on a PCG-GRT260G, w/Windows XP Home (SP3).

Direct download

ftp://download.sony.com/US/pc/SOASSL-10133900-US.EXE

I was doing a fresh reload of this machine and I think the issue is Sony hasn't updated their links for some of the utilities for their older laptops. The version of SOASSL... that's provided on the PCG-GRT260G drivers download area is SO-P30800803IJ03US.exe...from 11/14/2003. That was before XP SP2 (not to mention SP3) was released I believe. In any case, the link Pete provided worked like a charm!

Share this post


Link to post
Share on other sites

Just wanted to say you guys are the best! I searched everywhere for this fix and you guys nailed it! It was driving me bonkers! Love the Dog pics too! Thanks!

Thank you for the positive feedback. That helps the next guy who googles it. Saw the thread and even before clicking it I remembered encountering the problem and solution so I figured I would have to remember where I had helped someone solve this problem. Glad to see it was just a confirmation that this is the fix.

Share this post


Link to post
Share on other sites

Hi, I had the same problem with a Sony VAIO Notebook PCG-TR3AP, I did a clean XP Pro Install and installed all the drivers from the Sony Support page including a Shared Library, but still had that problem... until I installed the Shared Library executable that Pete_C posted, and resolved the issue Thanx!! everything is working great now :D

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this