Sign in to follow this  
cowsgonemadd3

Bought A New Hd And Computer Does Not See It

Recommended Posts

Okay so you all were helping me in with my HD problem earlier.

I bought a new 640gb WD HD and a little ide to usb thing.

The drive works fine and so it was not the drive but the virus. I did a scan through my laptop on the HD and it found a couple of viruses.

I have not used AVG yet but I did use Adaware and Malwarebytes.

Anyways the old drive was IDE and the new drive is sata.

I hooked up my new drive(old one is not in) to sata 1 on the Motherboard.

I go to set up Xp with my cd and the pc can't find the drive.

So what is up with that?

Share this post


Link to post
Share on other sites

How old is the motherboard or better yet, do you know what model the motherboard is? Your motherboard may only support SATA150 while the drive is most likely SATA300. If that's the case, you need to change a jumper on the Hard Drive to set it SATA150 mode. If not, it's possible you have a bad drive. Have you tried the drive in another computer?

Share this post


Link to post
Share on other sites

I looked up the board and it appears it supports only SATA150 so you need to move a jumper on the drive to set it into SATA150 mode since it's factory default is SATA300 mode.

Share this post


Link to post
Share on other sites

Windows XP cant see SATA hard drives(controllers) by default. Most modern motherboards will allow the XP installer to access the drives in IDE mode. I am not sure yours can do that. You may want to look in the bios for an option like that.

You may have to load the sata drivers manually. Here are the via floppy sata drivers you need.

Share this post


Link to post
Share on other sites

My XP Home disc saw my SATA drives without a problem and I didn't have them in IDE mode. No external drivers were required. I still think that he needs set his new drive in 150 mode since that's all his motherboard supports. If the drive is in 300 mode, his motherboard will not see it.

Share this post


Link to post
Share on other sites

It does not say on my drive how to set it to ata 150. Do you know how? It does have 4 slots on it. I put it on the second slot.

It is a Western Digital SE16 hard drive.

Edited by cowsgonemadd3

Share this post


Link to post
Share on other sites

in that image, it should be be where is says OPT1. That will limit it to 150 mode so that motherboard can use it. If the motherboard sees it but the Windows disc doesn't, you may just have to switch the drive over to IDE mode in the BIOS to install windows. I never had to do that with mine when I installed XP home on my last computer and this computer and I certainly didn't have to do it with Vista x64 on Windows 7 x64 on this computer.

Share this post


Link to post
Share on other sites
I did it like this and the bios nor the windows disk still does not see my drive. The bios saw my drive before....

http://wdc.custhelp.com/cgi-bin/wdc.cfg/ph...amp;p_topview=1

If it is not even showing up at the hardware level(in the bios), this does not seem to be nothing to do with sata drivers. Are you using opt1 as shown in the diagram?

Their is a chance your new drive is bad. I get DOA drives all the time. For testing purposes, you should see if it works with your usb-to-sata adapter.

Share this post


Link to post
Share on other sites

I am back from my beach trip. I plug my drive in again and make sure the jumper is set on the number 2 prongs. I use a new jumper I found....

Anyways it shows the drive in the bios now but windows disk can't find it. When I hit tab "to enter user" it says NOTICE:

The number of disks is not adequate to create a raid.

I have just one hard drive and it is set on the "SATA 1" port.

What do I do now?

Share this post


Link to post
Share on other sites

It sounds like you have the SATA set up to run in RAID in which you need 2 or more drives. Disable RAID in your BIOS and then try.

Share this post


Link to post
Share on other sites

You do not need to create a raid device. The problem is the Windows installer does not know how to use your sata controller. That is why you have to load the sata drivers during the install. One method would be to temporarily install a floppy drive. The second method would be to incorporate the sata drivers in a new xp install cd. This second method would allow you to install without a floppy drive.

How to slip stream your sata drivers

Share this post


Link to post
Share on other sites

You motherboad manufature has the files you need. choose the drivers marked "VIA VT8237® SATA RAID Driver (For floppy driver)"

Using nlite, point to the drivers in this folder(the one you downloaded from above)

VIA_VT8237_SATARAID_Floppy\VIA_RAID_Floppy\i386\NT5

edit added later//

the drivers you found may have also worked, but I am certain the drivers on the msi site are correct.

Share this post


Link to post
Share on other sites

"VIA_VT8237_SATARAID_Floppy\VIA_RAID_Floppy\i386\NT5"

I did not see that option. I just hit add to the files by hitting driver on the program.

Now it see's the HD and is installing windows.

Thanks a lot! What a mess. I hope this thread helps others like me new to SATA drives and saves them some time.

Oh and one more thing, wow do sata drives move. XP installed in like 5 minutes!

Edited by cowsgonemadd3

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this