Sponsored By

Sign in to follow this  
Falcon1986

Setting Up A Ubuntu Webserver To Test Wordpress

Recommended Posts

Hello all!

I have a Ubuntu 8.10 32-bit desktop installation on my laptop that I would like to use for testing some WordPress stuff before transferring to my Linux-based web host. I found a guide on how to set up a LAMP server. Although this will be a "testing" environment, I don't want the server to start every time I log into Ubuntu.

I have never run virtualization software before, but do you think that would be the best way to go with this? I am thinking about using VirtualBox within Ubuntu then installing the server flavour of the OS to run the server.

What are your thoughts and recommendations? Do you know of a better way of doing this?

Thanks in advance for any input you can provide.

Share this post


Link to post
Share on other sites

Native would be simpler than virtualized. If you really don't want the daemons running all the time you can control them manually, but I wouldn't bother unless you're short on memory.

Share this post


Link to post
Share on other sites

there is no difference in the server version and the desktop version, except the GUI (server version has non by default). The only reason there is a Server version is because some people can not get out of their heads that they should be different.

under system --> administration --> services you can set if a service starts or not at boot..

of wordpress it would be apache..

but as JCL stated.. both apache and mysql take almost no resources unless you are accessing them..

Share this post


Link to post
Share on other sites

EDIT - Please disregard. Seems as though the default files contained within the www folder are locked but can be deleted. I can create and edit new files. ^_^

It's me again!

So I got Apache2, MySQL and PHP5 installed successfully using the guide I found here specifically for Ubuntu 8.10 Desktop.

However, I can't seem to assign my username to the www-data group that the tutorial instructs me to make. I believe something is wrong with the command...

useradd falcon1986 www-data

...because I always get a list of possible options that the command should contain. I also came across an alternative using usermod...

usermod -a -G www-data falcon1986

...but that does not help at all. It returns saying that I am already a member of that group. If it matters any, I noticed the same thing through GUI of System > Administration > Users and Groups. I have logged out and logged back in on every attempt, but whenever I try to edit files in /home/falcon1986/www I get the warning...

Could not save the file /home/falcon1986/www/index.html.

You do not have the permissions necessary to save the file. Please check that you typed the location correctly and try again.

...and the file icons themselves have a padlock emblem on them.

How do I get around this? Thanks for your input.

Edited by Falcon1986

Share this post


Link to post
Share on other sites

IMO it's easier to use mod_userdir. When it's enabled (and properly configured) http://host/~user/ will be mapped to ~user/public_html/. This is a nice private directory owned by the user, so you don't have screw around with groups and file ownership. Just

# Permit traversal of $HOME
$ chmod o+x ~
# Permit read and traversal of public_html
$ chmod o+rx ~/public_html
# Permit read and traversal of directories
$ find ~/public_html -type d -exec chmod o+rx {} \;
# Permit read of normal files
$ find ~/public_html -type f -exec chmod o+r {} \;

(You can limit access to the www-data group with ACLs, but even writing ACL I can feel my sanity slipping away....)

I don't think I've ever used the global www directories on my private servers; everything goes into userdirs.

If you want to use the global directories or restrict access to ~/public_html to www-data (without ACLs), you can use the newgrp utility to change your current group or sg to execute a command under a different group. I think it's easier to maintain permissions than flip between groups, though, and if you're working in a GUI you might not be able to change your current group on the fly. The chmod g+s in the article you linked to is intended to remove the need to change groups, but it only controls the default group for newly created files.

Share this post


Link to post
Share on other sites

Thanks, 'jcl'! I believe I'll leave it the way it is for now, since everything is working fine. However, I will remember your recommendation should I need to set up a web directory for another user.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this