Sponsored By

Sign in to follow this  
baker7

Vnc4server Problem

Recommended Posts

I cant seem to run VNC4 Server and successfully connect to my linux machine's desktop - It shows that it has a valid display #, but when I try to use a VNC viewer from my windows box, I get a password box, I enter the right password, and then get "VNC Authentocation failed" which means i cannot connect to the linux box:

[email protected]{pts/0}:/root> vncserver :0

You will require a password to access your desktops.

Password:
Verify:

Warning: Eliveserver.buddy-baker.us:0 is taken because of /tmp/.X0-lock
Remove this file if there is no X server Eliveserver.buddy-baker.us:0
A VNC server is already running as :0
[email protected]{pts/0}:/root> vncserver :6
Found /usr/share/vnc-java for http connections.

New 'Eliveserver.buddy-baker.us:6 (brian)' desktop is Eliveserver.buddy-baker.us:6

Creating default startup script /home/brian/.vnc/xstartup
Starting applications specified in /home/brian/.vnc/xstartup
Log file is /home/brian/.vnc/Eliveserver.buddy-baker.us:6.log

[email protected]{pts/0}:/root>

is there any way to start this thing and allow connections to the linux box from windows? It was running before, but I couldnt start it right, and I had no password, so I had to install it again on elive.

Any help would be appreciated....

Brian

Share this post


Link to post
Share on other sites

Tried this again, and made a password for my accounts, the thing is that I have to start it from a shell before I can vnc - I can use vncviewer4 or my older version of vnc, but want to set up specific display numbers for certain logins so I do NOT have to be root initially - I was able to start vncserver and then do:

192.168.1.60:display#

Then it came up with a password prompt, and I entered it and it worked - I don't know what the heck I did, right or wrong, but may need some more help on this: I get this right, and I can go live on the net next week :)

Brian

Share this post


Link to post
Share on other sites

probably the difference between system vnc password and logged in user password

I personly like NX much better. you do not even need X running just installed.

see no machine's web site http://www.nomachine.com/

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this