Sponsored By

Sign in to follow this  
Falcon1986

Activate Wifi In Ubuntu 8.04

Recommended Posts

I am hoping that someone can help me with this. I have a fairly new installation of Ubuntu 8.04 (updated) on my HP Pavilion DV7-1034ca notebook, but the wireless adapter (Intel WiFi Link 5100AGN) is not detected. The status LED on the notebook indicates that it is off. In Windows Vista I would simply launch the HP Wireless Utility to turn it on/off, but I can't seem to do that in Ubuntu since it wasn't detected in the first place.

After successfully following the steps in this post I rebooted and, although there are several wireless options in the network manager, the adapter is still disabled.

I am new to Linux, so does anyone know how I can get the Intel WiFi Link 5100AGN wireless adapter activated to be able to connect to wireless networks?

Thanks in advance.

Share this post


Link to post
Share on other sites

is this 32 or 64 bit.

The issues you are seeing is related to the firmware not loading, most likely. if its 64bit try the 32bit as it looks like the driver and firmware are not 64bit ready.

then write intel and use big words asking why they are not providing better drivers.

there is a Kernel Bug Listed for this Chip

https://lists.linux-foundation.org/pipermai...ber/019730.html

it looks like Intel driver does not work..

Share this post


Link to post
Share on other sites

The new 2.6.27 Kernel is list office support for your wireless chip set now.. Maybe intel fixed the driver

Share this post


Link to post
Share on other sites

Thanks for the update, 'iccaros'.

I did find some promising forum posts through Google saying that Intrepid Ibex works out of the box with this wireless adapter.

Share this post


Link to post
Share on other sites

I found this guide and was considering going ahead with the upgrade. I use Windows primarily and Ubuntu just to play around with, so I do not mind using the beta. However, since the final release is scheduled for the end of October I think I'll just wait.

I noticed that Ubuntu 8.04 also does not seem to like working with my audio adapter (IDT HD Audio adapter). I always get this pulse-like/stuttering sound when I turn the volume up to 100% and nothing isn't even playing.

Share this post


Link to post
Share on other sites

Just downloaded the final release of Ubuntu 8.10 via BitTorrent. The speeds are unbelievably fast at the moment!

It came slightly early (no surprise!). On my way to burn it to disc...

Share this post


Link to post
Share on other sites

It's coming in pretty fast on BitTorrent and the Ubuntu tracker is loaded with over 5K seeders!

Anyway, I decided to run the Ubuntu 8.10 LiveCD to test whether my audio and wifi issues were properly detected. So far, I haven't configured the wifi as yet, but I see where I can enter the relevant information. However, I still have a problem with my audio. Whenever a sound plays there is still a lot of stuttering and echoes in a pulse-like tone.

Whether I choose "Autodetect", "ALSA", "OSS" or any one of those on "Intel HDA STAC92xx digital/analog" and test the audio I either get that same sound coming from the speakers or no sound at all. Bummer! :(

Share this post


Link to post
Share on other sites
It's coming in pretty fast on BitTorrent and the Ubuntu tracker is loaded with over 5K seeders!

Anyway, I decided to run the Ubuntu 8.10 LiveCD to test whether my audio and wifi issues were properly detected. So far, I haven't configured the wifi as yet, but I see where I can enter the relevant information. However, I still have a problem with my audio. Whenever a sound plays there is still a lot of stuttering and echoes in a pulse-like tone.

Whether I choose "Autodetect", "ALSA", "OSS" or any one of those on "Intel HDA STAC92xx digital/analog" and test the audio I either get that same sound coming from the speakers or no sound at all. Bummer! :(

if you are not using you parallel port and serial port, try turning them off in the BIOS.. I have seen that chip collide with either, causing the issue you are seeing..

I am not saying it will fix your issues, but it may

also a Live cd can show performance issues depending on how much ram you have

Share this post


Link to post
Share on other sites

Thanks for the reply, 'iccaros'. I will try to see if I can disable those ports.

The laptop that I am using for this Ubuntu installation is quite good in terms of hardware specifications, so I do not believe I am limiting OS performance in that regard. Things run smoothly with an Intel Core 2 Duo P8400 2.26GHz CPU and 4GB of RAM.

UPDATE: Just realized - my notebook doesn't have serial or parallel ports and, furthermore, the BIOS is restricted to editing except for maybe the time and boot devices.

Edited by Falcon1986

Share this post


Link to post
Share on other sites

UPDATE: I was finally able to get the audio to work after reading this bug report. It turns out I only had to add "options snd-hda-intel enable_msi=1" to /etc/modprobe.d/alsa-base and reboot! BTW, everything in the 'Sound Playback' sections of System > Sound was set to "Auto Detect". :thumbsup:

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this