Sponsored By

Sir_Siddy

Writing To A Samba Share

Recommended Posts

I just reformated many of my drives on my home server (running linux) to ext3. They were formerly formated to ntfs which I would mount with ntfs-3g. When they were ntfs I used the umask 000 option so all the drives were writeable and readable to everyone. Insecure, but since it is a private network it was not a big deal. However, there is no similar option with ext3. I changed the permissions of my drives using "chown -R sid"

All computers accessing the samba shares have the user name sid and the same password, however I cannot write to any of the shares. Is there something I am missing?

Edited by Sir_Siddy

Share this post


Link to post
Share on other sites

Ah whats stranger is that my windows computer CAN write to the drives. However my linux laptop cannot. Both have the same username and password.

Share this post


Link to post
Share on other sites

sorry but I am totally lost with your post..

you have a windows box you are tring to share out or linux box..

you can not use chmod on a NTFS partition as windows uses a totally different format for its permissions..

and windows can not read and ext2 or ext3 format..with out commercial drivers..

in the samba (smb.conf) config (if its a linux box sharing) you set anonymous access, where that is is hard to say, but there are two ways of finding it

open /etc/init.d/samba and see where it points to its config

try under /etc/samba/smb.conf

or as root cd to /

then do a find . -name smb.conf

if its a windows box sharing out its shares... then look at the windows logs and see what error you are getting, from there we can trouble shoot this more..

Share this post


Link to post
Share on other sites

Ah sorry I didnt specify earlier. It is a linux box using samba to share its drives. Here is my smb.conf


browseable = yes
read only = no
public = yes
workgroup = WORKGROUP

[D]
path = /home/sid/Drives/D
browseable = yes
read only = no
public = yes

[E]
path = /home/sid/Drives/E
browseable = yes
read only = no
public = yes

[500g]
path = /home/sid/Drives/500g
browseable = yes
read only = no
public = yes

This same smb.conf worked across all computers when my drives were formated with NTFS ( I was using ntfs-3g with the option umask 000 to mount them). I reformatted all of them to use ext3 instead and now my linux laptop cannot write to these shares. However, my windows PC is able to. Do you need to see my fstab as well?

EDIT: I added my fstab just in case

# /etc/fstab: static file system information.
#
# <file system> <mount point> <type> <options> <dump> <pass>
proc /proc proc defaults 0 0
/dev/sda3 / ext3 defaults,errors=remount-ro 0 1
/dev/sda7 none swap sw 0 0
/dev/hda /media/cdrom0 udf,iso9660 user,noauto 0 0
/dev/fd0 /media/floppy0 auto rw,user,noauto 0 0


/dev/sdb1 /home/sid/Drives/Mybook ext3 users,rw,auto 0 0

/dev/sdc1 /home/sid/Drives/500g ext3 users,rw,auto 0 0

/dev/sda5 /home/sid/Drives/D ext3 users,rw,auto 0 0

/dev/sda6 /home/sid/Drives/E ext3 users,rw,auto 0 0

Edited by Sir_Siddy

Share this post


Link to post
Share on other sites

thanks

I always add this line

socket options = TCP_NODELAY SO_RCVBUF=8192 SO_SNDBUF=8192

it helps speed up samba transfers

are you logging in If not add

guest ok = yes

also you can set permissions on the folder you are sharing (or drive)

chmod 777 -R /foldername

it will keep these setting, the reason NTFS used the UMASK at mount is because of the differences between windows and unix permissions.

what is the error your linux users are getting, permission denied on write or mount?

how are the linux users mounting the samba share... it could be in there permissions.

or are these users on the same box as the samba share.. and since you have this in your home folder they have auto read but no write permissions (note when you umasked the ntfs it allows all to write to this..)

I would also move these shares out of your home folder and move them to /mnt

it is the "standard" for mounting drives to and will limit possible security issues of people following links up into your home folder..

hope these questions help...

Share this post


Link to post
Share on other sites

I think changing the permissions did it. Im still getting a hang of unix permissions Thanks :) . I also added the line to speed up transfers. What exactly does that line do?

Share this post


Link to post
Share on other sites

it makes samba buffer request and sends into compleat packets, instead of mangling packets the way Windows does..

This make the client not have to process packets as much..

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now