Sponsored By

Sign in to follow this  
bozodog

Stink'in Power Supply

Recommended Posts

Yep, hubby's PS burned up yesterday, *again. This is the second one in 3 years. ?!?? Just wondering if there may be an underlying problem, as my ole Dell

is over 7 years old without a problem.

I don't know details, but his machine is a "bare bones" build from Tiger Direct. The PS that came with the case was pitifully under built. (average size, but

small componants inside) The replacement was a substantial difference, with some weight and size to it. The first one just failed, stopped working. The second, woke me up at 4am smelling like a skunk. If fact, I thought BOZO the boxerdawg did get skunked in the night. The computer stopped running about noon and the PS was VERY hot.

It's no big thing, but I really wonder if something is wrong with the mother board or something else to cause PS failures like this.

Share this post


Link to post
Share on other sites

Glad you caught it before it could do some real damage. Even if you clean out your computer, chances are there's still a bunch of lint inside the power supply. They do go bad. There's not a lot inside the computer could cause it.

Mark

Share this post


Link to post
Share on other sites

Wow, a skunk smell, that is interesting.

As to it going bad, I think it is just the luck of the draw.

Share this post


Link to post
Share on other sites

Yeah, it was kinda burning rubber, plastic, electrical.... VERY close to a skunk smell. I know, Bozo got skunked a few springs ago. Pheew! Although, he has promised never to do that again. He sure didn't like the tomato juice bath and several dips in the icy cold river at the park... No way was I gonna bathe him in the house!

Share this post


Link to post
Share on other sites

Well, we took the PS apart. It was a bit dirty, but not that bad. Looks like the fan failed, it was tighter than a new pair of shoes.

fan failed>>>>overheated and smelled like a skunk.

Share this post


Link to post
Share on other sites
Yep, hubby's PS burned up yesterday, *again. This is the second one in 3 years. ?!?? Just wondering if there may be an underlying problem, as my ole Dell

is over 7 years old without a problem.

I don't know details, but his machine is a "bare bones" build from Tiger Direct. The PS that came with the case was pitifully under built. (average size, but

small componants inside) The replacement was a substantial difference, with some weight and size to it. The first one just failed, stopped working. The second, woke me up at 4am smelling like a skunk. If fact, I thought BOZO the boxerdawg did get skunked in the night. The computer stopped running about noon and the PS was VERY hot.

It's no big thing, but I really wonder if something is wrong with the mother board or something else to cause PS failures like this.

Skunk was probably hot rubber.

My first question is does this computer have a UPS with Automatic Voltage Regulation? If not, I would suspect power fluctuations when branches hit lines in a winter storm. Did you have one recently?

The other thought would be a pinched or shorted wire inside the case or shorted motherboard or just to many things drawing power. Do you have lots of lights, fans etc?

Share this post


Link to post
Share on other sites

No, no and no Pete. It does run on a top of the line Belkin surge protector. The fan failed, plain and simple. Anyway, we can't find one in this podunk town, so we'll order one today.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this