Sir_Siddy

Drive Not Being Seen In Ubuntu

Recommended Posts

Ok

That mounted my first external. Im going to go check out how to mount the NTFS now.

Also I added this to the fstab. Is it alright??

/dev/sdb1	/media/Mybook	vfat	defaults,unmask=222,noauto,users 0 0

Edited by Sir_Siddy

Share this post


Link to post
Share on other sites

Ok

I did the command

sudo mount /dev/sdc1 /media/500g -t ntfs

It mounted the drive, but I cannot acess it. It says I do not have permission. How do I set that?

Also

I added this to fstab too

/dev/sbc1	/media/500g   ntfs 	defaults,unmask=222,noauto,users 0 0

UPDATE

Im not sure exactly what fstab does, but doesnt it allow for things to mount on boot? I just restarted and neither of the drives were mounted. Did I put the wrong stuff into fstab?

Edited by Sir_Siddy

Share this post


Link to post
Share on other sites

The umask option should let you access it as any user. Have you unmounted and remounted your ntfs drive since adding the umask option to your fstab file system?

Can you access the ntfs drive as root user?

Share this post


Link to post
Share on other sites

Ahh now I can acess it after installing the ntfs-3g drivers. I can fully acess both drives now. I just need them to mount on start. I changed the fstab to use ntfs-3g instead of just ntfs

Thanks for all your help everybody!! :D

Edited by Sir_Siddy

Share this post


Link to post
Share on other sites

Cool :-) Glad you found the solution.

When you mean boot at start, do you mean mount ? To have them mount automatically, just remove the noauto option from your fstab

Share this post


Link to post
Share on other sites

ahh thank you thats exactly what I meant

Well my fstab entries now are

/dev/sdb1	/media/Mybook	vfat	defaults,unmask=222,users 0 0

/dev/sbc1 /media/500g ntfs-3g defaults,unmask=222,users 0 0

but they still dont mount on boot.

Edited by Sir_Siddy

Share this post


Link to post
Share on other sites

I have had typos like that really cause headaches trouble shooting a problem. I have a hunch it would work with file system "ntfs" now that you have the correct spelling of umask. If you want to be able to write to your vfat drive, change the umask to 000. Make sure you do not do that to your ntfs drive. Writing to it may cause file system corruption.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...