Sir_Siddy

Drive Not Being Seen In Ubuntu

Recommended Posts

I have two my book external harddrives attached to my computer running ubuntu. One is 250 gigs and one is 500g. Ubuntu will only show the 250 gig drive though. The other one doesnt show up in /media. How do I get the other drive to show up?

Share this post


Link to post
Share on other sites

could you post the output of the following command

cat /etc/fstab

also post the output of this command

dmesg | grep sda

Share this post


Link to post
Share on other sites

[email protected]:~$ cat /etc/fstab
# /etc/fstab: static file system information.
#
# <file system> <mount point> <type> <options> <dump> <pass>
proc /proc proc defaults 0 0
# /dev/sda3
UUID=4cf62b08-608f-4db5-8180-383e83e5053f / ext3 defaults,errors=remount-ro 0 1
# /dev/sda7
UUID=b2006404-5cf8-4a27-a600-d3d91e4f4af1 none swap sw 0 0
/dev/hda /media/cdrom0 udf,iso9660 user,noauto 0 0
/dev/fd0 /media/floppy0 auto rw,user,noauto 0 0

[email protected]:~$ dmesg | grep sda
[ 34.474157] SCSI device sda: 488397168 512-byte hdwr sectors (250059 MB)
[ 34.474353] sda: Write Protect is off
[ 34.474355] sda: Mode Sense: 00 3a 00 00
[ 34.476440] SCSI device sda: write cache: enabled, read cache: enabled, doesn't support DPO or FUA
[ 34.476661] SCSI device sda: 488397168 512-byte hdwr sectors (250059 MB)
[ 34.476671] sda: Write Protect is off
[ 34.476673] sda: Mode Sense: 00 3a 00 00
[ 34.476685] SCSI device sda: write cache: enabled, read cache: enabled, doesn't support DPO or FUA
[ 34.476691] sda: sda1 sda2 < sda5 sda6 sda7 > sda3
[ 34.572673] sd 0:0:0:0: Attached scsi disk sda
[ 36.505867] EXT3-fs: sda3: orphan cleanup on readonly fs
[ 36.505949] EXT3-fs: sda3: 6 orphan inodes deleted
[ 45.696073] EXT3 FS on sda3, internal journal

Share this post


Link to post
Share on other sites

Hmm. I am not seeing what I thought I might have. If you could, try this. If the drive you need to read is plugged in your usb, remove it. Then plug it in, wait about 30 seconds then try this command. Post the output

sudo tail /var/log/messages

Share this post


Link to post
Share on other sites

would you not do a mount and see what the drive mounted is named

then

grep for the other..

also if the bigger drive is NTFS, I do not Believe that NTFS driveres are loaded by default in Ubuntu..

http://ubuntuforums.org/showthread.php?t=217009

Share this post


Link to post
Share on other sites

I beleive both are FAT

Aug 17 11:29:44 linuxrig kernel: [  385.273175] input: Western Digital External HDD as /class/input/input7
Aug 17 11:29:44 linuxrig kernel: [ 385.273199] input: USB HID v1.11 Device [Western Digital External HDD] on usb-0000:00:02.2-3
Aug 17 11:29:49 linuxrig kernel: [ 390.264878] scsi 6:0:0:0: Direct-Access WD 5000YS External 106a PQ: 0 ANSI: 4
Aug 17 11:29:49 linuxrig kernel: [ 390.267611] SCSI device sdc: 976773168 512-byte hdwr sectors (500108 MB)
Aug 17 11:29:49 linuxrig kernel: [ 390.268107] sdc: Write Protect is off
Aug 17 11:29:49 linuxrig kernel: [ 390.269479] SCSI device sdc: 976773168 512-byte hdwr sectors (500108 MB)
Aug 17 11:29:49 linuxrig kernel: [ 390.269978] sdc: Write Protect is off
Aug 17 11:29:49 linuxrig kernel: [ 390.269987] sdc: sdc1
Aug 17 11:29:49 linuxrig kernel: [ 390.279025] sd 6:0:0:0: Attached scsi disk sdc
Aug 17 11:29:49 linuxrig kernel: [ 390.279063] sd 6:0:0:0: Attached scsi generic sg2 type 0

Also when I plugged it back in, I got a message saying found new device what do you want to do and then a option to open in new window. I pressed that but nothing popped up and there is still nothing new in /media

Share this post


Link to post
Share on other sites

try this

under media create a folder

then try to mount it to that folder

mount /dev/sdc1 /media/foldername

at the same time tail -v /var/syslog

I think its v anyways .. or maybe that is just unix.. you can try it with out the -v..

Share this post


Link to post
Share on other sites
tail?

I think its -f for Linux

NAME

tail - output the last part of files

SYNOPSIS

tail [OPTION]... [FILE]...

DESCRIPTION

Print the last 10 lines of each FILE to standard output. With more than one FILE, precede each with a header giving the file name. With no FILE, or when FILE is -, read standard input.

Mandatory arguments to long options are mandatory for short options too.

--retry

keep trying to open a file even if it is inaccessible when tail starts or if it becomes inaccessible later -- useful only with -f

-c, --bytes=N

output the last N bytes

-f, --follow[={name|descriptor}]

output appended data as the file grows; -f, --follow, and --follow=descriptor are equivalent

-F

same as --follow=name --retry

-n, --lines=N

output the last N lines, instead of the last 10

--max-unchanged-stats=N

with --follow=name, reopen a FILE which has not changed size after N (default 5) iterations to see if it has been unlinked or renamed (this is the usual case of rotated log files)

--pid=PID

with -f, terminate after process ID, PID dies

-q, --quiet, --silent

never output headers giving file names

-s, --sleep-interval=S

with -f, sleep for approximately S seconds (default 1.0) between iterations.

-v, --verbose

always output headers giving file names

--help

display this help and exit

--version

output version information and exit

If the first character of N (the number of bytes or lines) is a `+', print beginning with the Nth item from the start of each file, otherwise, print the last N items in the file. N may have a multiplier suffix: b for 512, k for 1024, m for 1048576 (1 Meg).

With --follow (-f), tail defaults to following the file descriptor, which means that even if a tail'ed file is renamed, tail will continue to track its end. This default behavior is not desirable when you really want to track the actual name of the file, not the file descriptor (e.g., log rotation). Use --follow=name in that case. That causes tail to track the named file by reopening it periodically to see if it has been removed and recreated by some other program.

SEE ALSO

The full documentation for tail is maintained as a Texinfo manual. If the info and tail programs are properly installed at your site, the command

info tail

should give you access to the complete manual.

Share this post


Link to post
Share on other sites

The tail command is not nessasary to mount and view the drive. Iccaros was showing you a way to view what is happening, and if it fails to mount you would get extra info to show you what caused the failure.

Share this post


Link to post
Share on other sites

does this apply to all dual boots with win and linux

i have ubuntu and win xp on adual boot

ubuntu beeing on a seperate drive

and the only place i can find that drive is in

computer management

i cant find it in my compt

nor device manager is this

always the case like

sir siddy has

Share this post


Link to post
Share on other sites

Well this is what I got

[email protected]:/var/log$ tail -f syslog
Aug 19 11:42:16 linuxrig /usr/sbin/cron[4619]: (CRON) INFO (Running @reboot jobs )
Aug 19 11:42:19 linuxrig kernel: [ 53.215494] eth0: no IPv6 routers present
Aug 19 11:42:22 linuxrig kdm_greet[4679]: Can't open default user face
Aug 19 11:42:26 linuxrig kdm_greet[4679]: Internal error: memory corruption dete cted
Aug 19 11:42:33 linuxrig hald: mounted /dev/sdb1 on behalf of uid 1000
Aug 19 11:56:51 linuxrig smbd[4939]: [2007/08/19 11:56:51, 0] lib/util_sock.c:wr ite_data(562)
Aug 19 11:56:51 linuxrig smbd[4939]: write_data: write failure in writing to c lient 192.168.1.2. Error Connection reset by peer
Aug 19 11:56:51 linuxrig smbd[4939]: [2007/08/19 11:56:51, 0] lib/util_sock.c:se nd_smb(769)
Aug 19 11:56:51 linuxrig smbd[4939]: Error writing 4 bytes to client. -1. (Con nection reset by peer)
Aug 19 12:09:01 linuxrig /USR/SBIN/CRON[4976]: (root) CMD ( [ -d /var/lib/php5 ] && find /var/lib/php5/ -type f -cmin +$(/usr/lib/php5/maxlifetime) -print0 | x args -r -0 rm)
Aug 19 12:10:52 linuxrig kernel: [ 1764.220916] NTFS driver 2.1.28 [Flags: R/O M ODULE].
Aug 19 12:10:53 linuxrig kernel: [ 1764.261696] NTFS volume version 3.1.
Aug 19 12:12:47 linuxrig gconfd (sid-5033): starting (version 2.18.0.1), pid 5033 user 'sid'

also I cant acess the test folder I created without root.

The files from my second drive are visible inside of it though.

Share this post


Link to post
Share on other sites

It seems ive done something stupid as well. I tried changing the mount point on my working 250 G drive to /media/samba so I could share it. I did it through right clicking it and going to properties. When I unplugged and then plugged in the drive I got the box asking me what to do with the drive. I said open it, but nothing happened. Also the drive is not present in /media or /media/samba.

Share this post


Link to post
Share on other sites

You could add an entry to your /etc/fstab file. With this entry you can add read permissions for all users using the umask option. Below is from mine

/dev/sda2	   /home/shane/ntfs	  ntfs		defaults,umask=222,noauto,users  0 0

Of course you will need to change the device name and mount point.

Share this post


Link to post
Share on other sites

It just the way of setting permissions on the FS you are mounting if you don't want to use the defaults.

But keep in mind that UMASK doesn't use same permission as the system permissions, As a matter of fact it is the exact opposite (inverse to be precise)

Let use - rw- rw- rw- as an example == which means (in order) User , Groups and World(everyone else) have read/write access. This would also be written as 555. Doing the math (keeping in mmd MAXIMUM is 777) for UMASK then those same permission would be 222.

OR to set all permissions (777) in UMASK use 000.

Confused now?? LOL

Share this post


Link to post
Share on other sites

222 will give you read and execute permissions(not write) for everyone. This way you do not have to be logged in as root to read the directory

Share this post


Link to post
Share on other sites

Appologies.....

My error started in my representation of properties.

what I have in other post is NOT 555..it's 666.....or (111 in UMASK) and as I was writing I just wrote what permission I had...

- r-x r-x r-x IS 555 and read and execute....

Sorry for confusion. It was early and I hadn't had coffee yet I guess.

Share this post


Link to post
Share on other sites

Well looks like you have FAT drives right?

then you need command like following in your /etc/fstab

/dev/hdb1 /media/fat_files vfat iocharset=utf8,umask=000 0 0

Get correct info (/dev/hdb1 etc) from sudo fdisk -l.

GREAT info on fstab can be found HERE

Mounting info found HERE

Edited by jwbirdsong

Share this post


Link to post
Share on other sites

For future reference, the possible values are

0	 -
1 execute
2 write
3 write/execute
4 read
5 read/execute
6 read/write
7 read/write/execute

(The value maps onto a three bit field rwx. Good excuse to practice octal->binary conversion.)

Share this post


Link to post
Share on other sites

Im sorry, Im not getting the time I need to work on this problem. Thanks for all your help and hopefully this weekend Ill be able to try out your ideas. Ill let you know what happens

Edited by Sir_Siddy

Share this post


Link to post
Share on other sites

Alright

Ive had some time to play around with my system again and this is where I am at

Neither of my drives mount when I connect them.

The 500 gig IS a NTFS filesystem. I thought I had made it Fat32 earlier but I guess I didnt.

My 250 gig external is at /dev/sdb

When I ran the command sudo mount /dev/sdb /media/Mybook

I got the error saying I needed to specify filetype. How would I do this? I tried -t fat32 but that didnt work. It said fat32 was not a recognized filesystem.

Share this post


Link to post
Share on other sites

I think that would be sdb1 (first partition on the drive )

also I think its vfat for fat 32

msdos is used for fat16 and older

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...