arachnid40

Acer Monitor

Recommended Posts

I have an Acer AL1917W 19inch LCD Ubuntu does not see the the resolution I use of 1440 x 900 and I get times when I boot to Ubuntu the screen goes black with a thin white line on the bottom or I get a floating box about not being supported, if I change my screen resolution I can make the box go away. The list of screen resolutions in Ubuntu does not show 1440 x 900. My video card is an Radeon 9200

I have the latest version of Ubuntu 7.04 and fully updated.

Edited by arachnid40

Share this post


Link to post
Share on other sites

LCDs can be tricky. I had a tough time getting my lcd tv to work. it is more or less just a big monitor. Eventually I found a method that worked. The idea is you need to find the correct modeline. With this info, you can add the correct info to your xorg.conf file.

below is a link to the method I used. The actual method is towards the end of the thread. Please ask any questions, I know it can be frustrating.

http://www.besttechie.net/forums/index.php...st=0#entry64776

If you can run the program Powerstrip from windows and post the modeline info it gives, I can help you with the rest.

Edited by shanenin

Share this post


Link to post
Share on other sites

I am trying to find advanced timings in Powerstrip so far I don't see it.

Share this post


Link to post
Share on other sites

r-click on the powertrip icon in the system tray, for it to appear in the tray you may have to run it then exit it out. then choose "display profiles", then "configure". You will see the advanced timings button.

Once you are on the advanced timings page, just right of the cancel button, their in a small button that will copy the timings to your clipboard.

Edited by shanenin

Share this post


Link to post
Share on other sites

PowerStrip timing parameters:

1440x900=1440,56,32,72,900,3,6,17,89100,272

Generic timing details for 1440x900:

HFP=56 HSW=32 HBP=72 kHz=56 VFP=3 VSW=6 VBP=17 Hz=60

Linux modeline parameters:

"1440x900" 89.100 1440 1496 1528 1600 900 903 909 926 +hsync +vsync

There ya go, thanks. Be patient with me I am old :-)

Share this post


Link to post
Share on other sites

Now you will need to edit your xorg.conf file. If you do it wrong your gui will guit working. If you want to paste your file into this post, I will show you what changes need to be made

You file should be located at /etc/X11/xorg.conf

Share this post


Link to post
Share on other sites
Now you will need to edit your xorg.conf file. If you do it wrong your gui will guit working. If you want to paste your file into this post, I will show you what changes need to be made

You file should be located at /etc/X11/xorg.conf

How do I open this file?

Share this post


Link to post
Share on other sites

Never mind I got it:

# /etc/X11/xorg.conf (xorg X Window System server configuration file)

#

# This file was generated by dexconf, the Debian X Configuration tool, using

# values from the debconf database.

#

# Edit this file with caution, and see the /etc/X11/xorg.conf manual page.

# (Type "man /etc/X11/xorg.conf" at the shell prompt.)

#

# This file is automatically updated on xserver-xorg package upgrades *only*

# if it has not been modified since the last upgrade of the xserver-xorg

# package.

#

# If you have edited this file but would like it to be automatically updated

# again, run the following command:

# sudo dpkg-reconfigure -phigh xserver-xorg

Section "Files"

FontPath "/usr/share/X11/fonts/misc"

FontPath "/usr/share/X11/fonts/cyrillic"

FontPath "/usr/share/X11/fonts/100dpi/:unscaled"

FontPath "/usr/share/X11/fonts/75dpi/:unscaled"

FontPath "/usr/share/X11/fonts/Type1"

FontPath "/usr/share/X11/fonts/100dpi"

FontPath "/usr/share/X11/fonts/75dpi"

FontPath "/usr/share/fonts/X11/misc"

# path to defoma fonts

FontPath "/var/lib/defoma/x-ttcidfont-conf.d/dirs/TrueType"

EndSection

Section "Module"

Load "i2c"

Load "bitmap"

Load "ddc"

Load "dri"

Load "extmod"

Load "freetype"

Load "glx"

Load "int10"

Load "type1"

Load "vbe"

EndSection

Section "InputDevice"

Identifier "Generic Keyboard"

Driver "kbd"

Option "CoreKeyboard"

Option "XkbRules" "xorg"

Option "XkbModel" "pc105"

Option "XkbLayout" "us"

Option "XkbOptions" "lv3:ralt_switch"

EndSection

Section "InputDevice"

Identifier "Configured Mouse"

Driver "mouse"

Option "CorePointer"

Option "Device" "/dev/input/mice"

Option "Protocol" "ExplorerPS/2"

Option "ZAxisMapping" "4 5"

Option "Emulate3Buttons" "true"

EndSection

Section "InputDevice"

Driver "wacom"

Identifier "stylus"

Option "Device" "/dev/wacom" # Change to

# /dev/input/event

# for USB

Option "Type" "stylus"

Option "ForceDevice" "ISDV4" # Tablet PC ONLY

EndSection

Section "InputDevice"

Driver "wacom"

Identifier "eraser"

Option "Device" "/dev/wacom" # Change to

# /dev/input/event

# for USB

Option "Type" "eraser"

Option "ForceDevice" "ISDV4" # Tablet PC ONLY

EndSection

Section "InputDevice"

Driver "wacom"

Identifier "cursor"

Option "Device" "/dev/wacom" # Change to

# /dev/input/event

# for USB

Option "Type" "cursor"

Option "ForceDevice" "ISDV4" # Tablet PC ONLY

EndSection

Section "Device"

Identifier "ATI Technologies, Inc. RV280 [Radeon 9200 PRO]"

Driver "ati"

BusID "PCI:1:0:0"

EndSection

Section "Monitor"

Identifier "AL1917W"

Option "DPMS"

EndSection

Section "Screen"

Identifier "Default Screen"

Device "ATI Technologies, Inc. RV280 [Radeon 9200 PRO]"

Monitor "AL1917W"

DefaultDepth 24

SubSection "Display"

Depth 1

Modes "1440x1440" "1400x1050" "1280x1280" "1280x1024" "1280x960" "1152x921" "1152x864" "1024x768" "832x624" "800x600" "720x400" "640x480"

EndSubSection

SubSection "Display"

Depth 4

Modes "1440x1440" "1400x1050" "1280x1280" "1280x1024" "1280x960" "1152x921" "1152x864" "1024x768" "832x624" "800x600" "720x400" "640x480"

EndSubSection

SubSection "Display"

Depth 8

Modes "1440x1440" "1400x1050" "1280x1280" "1280x1024" "1280x960" "1152x921" "1152x864" "1024x768" "832x624" "800x600" "720x400" "640x480"

EndSubSection

SubSection "Display"

Depth 15

Modes "1440x1440" "1400x1050" "1280x1280" "1280x1024" "1280x960" "1152x921" "1152x864" "1024x768" "832x624" "800x600" "720x400" "640x480"

EndSubSection

SubSection "Display"

Depth 16

Modes "1440x1440" "1400x1050" "1280x1280" "1280x1024" "1280x960" "1152x921" "1152x864" "1024x768" "832x624" "800x600" "720x400" "640x480"

EndSubSection

SubSection "Display"

Depth 24

Modes "1440x1440" "1400x1050" "1280x1280" "1280x1024" "1280x960" "1152x921" "1152x864" "1024x768" "832x624" "800x600" "720x400" "640x480"

EndSubSection

EndSection

Section "ServerLayout"

Identifier "Default Layout"

Screen "Default Screen"

InputDevice "Generic Keyboard"

InputDevice "Configured Mouse"

InputDevice "stylus" "SendCoreEvents"

InputDevice "cursor" "SendCoreEvents"

InputDevice "eraser" "SendCoreEvents"

EndSection

Section "DRI"

Mode 0666

EndSection

Share this post


Link to post
Share on other sites

xorg.conf is a text file, just like your fstab file. You can open it with any program that will open a text file. Gedit is the simplest to use. You have two options. You can start gedit by going to your program directory, I think it is located under accesories>>text editor. After the program is running you can use the open box to navigate to the file. A second option would be to tell gedit to open the file directly using a command line

gedit /etc/X11/xorg.conf

In windows you can do the same thing in the run box or the windows command line

notepad c:\windows\any_file.txt

after the file is open(for reading and editing) copy and paste the contents into the post

edit added later//

I see you posted before me :-)

Edited by shanenin

Share this post


Link to post
Share on other sites

you will need to make these changes to the file

change from this

Depth 24
Modes "1440x1440" "1400x1050" "1280x1280" "1280x1024" "1280x960" "1152x921" "1152x864" "1024x768" "832x624" "800x600" "720x400" "640x480"

You only really need to add your needed resolution, but you may as well remove some of the unneeded ones. Change the line to this

Depth 24
Modes "1440x900 "1024x768" "832x624" "800x600" "720x400" "640x480"

You also need to add the modeline to your Monitor Section

change from this

Section "Monitor"
Identifier "AL1917W"
Option "DPMS"
EndSection

Change it to this

Section "Monitor"
Identifier "AL1917W"
Option "DPMS"
Modeline "1440x900" 89.100 1440 1496 1528 1600 900 903 909 926 +hsync +vsync
EndSection

If you feel like being cautious, you could make a copy of this file before making changes. Just remember where it is located and what it is named. If anything goes wrong, you can revert back to it.

this is from your file

# If you have edited this file but would like it to be automatically updated

# again, run the following command:

# sudo dpkg-reconfigure -phigh xserver-xorg

I am not sure what that really does or if it is important. If this gives you trouble, maybe we should run that command. Wait and see if everything works before trying it.

Remember: since the file is located in an administrator area, you will need privileges to edit it. You will need to use the sudo command to open the file

sudo gedit /etc/X11/xorg.conf

Edited by shanenin

Share this post


Link to post
Share on other sites

I left out one part. You will have to restart your X-org server. The windows way of doing it would be a reboot.

This command entered may do it for you without rebooting

sudo /etc/init.d/gdm restart

Share this post


Link to post
Share on other sites

OOPS!

I messed up, it won't boot now. I am here from XP now, thank god for dual boot.

I am gonna try booting to unbuntu safe mode and see if I can put the file back the way it was and try again.

Share this post


Link to post
Share on other sites
That how you learn :-)

Is it not booting or just booting into a command line(no gui)

the command line thing, says :

parse error line 132

screen section

"1024x768" is not a valid keyword

How do I fix it in safe mode I tried but not sure how to bring up etc/x11/xorg.conf.

Do I need to re-install ubuntu?

Edited by arachnid40

Share this post


Link to post
Share on other sites

You don't need to reinstall. I am having fun(not crashing your system), I am so sick of working on windows computers, this is a nice change. i like linux.

the following commands will download a copy of the xorg.conf file i think should work for you, then copy it to the right spot

wget brighteyedcomputer.com/stuff/xorg.conf
sudo cp xorg.conf /etc/X11

make sure that is a capital X not a lowercasee x in X11(those our ones)

Share this post


Link to post
Share on other sites

WOOHOO!!!

Now we are cooking with gas. Thanks so much for your help. You have been invaluable to me.

Now a secondary but not that important question:

It takes a long time sitting on the GRUB Loader before I even get to my OS choices. Is this normal? Can I speed that up?

If I cannot it doesn't matter I can live with that way it is.

Share this post


Link to post
Share on other sites

I had a fun time helping. I am assuming you are getting your native resoution now, right?

edit the file called

/boot/grub/menu.lst

Their is an option called timeout. You can change the number in of that value to a smaller one.

Share this post


Link to post
Share on other sites

Yep getting the 1440 x 900 resolution now.

Am I correct in saying that to edit that file I would need to type "sudo gedit /boot/grub/menu.lst" in the terminal?

Share this post


Link to post
Share on other sites

All that does is shortens the countdown to choose the default OS. But thanks anyway I did want to increase that to al least 30 seconds instead of the 10 I had.

No big deal If I have to wait.

Share this post


Link to post
Share on other sites

just use the up and down arrows, when you get to the OS you want, just hit the enter key no waiting needed.

Share this post


Link to post
Share on other sites

I got a new video card, I have a MSI NX6200AX 256 ddr2. When I installed it my Ubunbtu would not go into the GUI. I decided to re-install Ubuntu into the same HD as my XP parttition and that worked well until I decided to fix the same problem I was having and it not recognizing my screen resolution of 1440 x 900. Now I am back to the same problem. How do I fix it?

Michael

New Pwerstrip post:

PowerStrip timing parameters:

1440x900=1440,112,152,232,900,3,6,33,137250,3

Generic timing details for 1440x900:

HFP=112 HSW=152 HBP=232 kHz=71 VFP=3 VSW=6 VBP=33 Hz=75

Linux modeline parameters:

"1440x900" 137.250 1440 1552 1704 1936 900 903 909 942 -hsync +vsync

Edited by arachnid40

Share this post


Link to post
Share on other sites

Thats odd. I would have assumed that your modeline parameters would be that same with either video card. I thought those were specific to your monitor. None the less, I need a copy of your xorgconfig file for your new card. I could then show your what changes to make, or just put a copy on my server again.

I found this method to fix you xorg . This will at least allow you to get to a gui. Then we can fix it.

type this command into your terminal. I think this will rewrite your config file

sudo dpkg-reconfigure xserver-xorg

assuming this allows you to get to a gui, then copy and paste your xorg file into this post.

Share this post


Link to post
Share on other sites

Section "Files"

FontPath "/usr/share/X11/fonts/misc"

FontPath "/usr/share/X11/fonts/cyrillic"

FontPath "/usr/share/X11/fonts/100dpi/:unscaled"

FontPath "/usr/share/X11/fonts/75dpi/:unscaled"

FontPath "/usr/share/X11/fonts/Type1"

FontPath "/usr/share/X11/fonts/100dpi"

FontPath "/usr/share/X11/fonts/75dpi"

FontPath "/usr/share/fonts/X11/misc"

# path to defoma fonts

FontPath "/var/lib/defoma/x-ttcidfont-conf.d/dirs/TrueType"

EndSection

Section "Module"

Load "i2c"

Load "bitmap"

Load "ddc"

Load "dri"

Load "extmod"

Load "freetype"

Load "glx"

Load "int10"

Load "type1"

Load "vbe"

EndSection

Section "InputDevice"

Identifier "Generic Keyboard"

Driver "kbd"

Option "CoreKeyboard"

Option "XkbRules" "xorg"

Option "XkbModel" "pc105"

Option "XkbLayout" "us"

Option "XkbOptions" "lv3:ralt_switch"

EndSection

Section "InputDevice"

Identifier "Configured Mouse"

Driver "mouse"

Option "CorePointer"

Option "Device" "/dev/input/mice"

Option "Protocol" "ExplorerPS/2"

Option "ZAxisMapping" "4 5"

Option "Emulate3Buttons" "true"

EndSection

Section "InputDevice"

Driver "wacom"

Identifier "stylus"

Option "Device" "/dev/wacom" # Change to

# /dev/input/event

# for USB

Option "Type" "stylus"

Option "ForceDevice" "ISDV4" # Tablet PC ONLY

EndSection

Section "InputDevice"

Driver "wacom"

Identifier "eraser"

Option "Device" "/dev/wacom" # Change to

# /dev/input/event

# for USB

Option "Type" "eraser"

Option "ForceDevice" "ISDV4" # Tablet PC ONLY

EndSection

Section "InputDevice"

Driver "wacom"

Identifier "cursor"

Option "Device" "/dev/wacom" # Change to

# /dev/input/event

# for USB

Option "Type" "cursor"

Option "ForceDevice" "ISDV4" # Tablet PC ONLY

EndSection

Section "Device"

Identifier "ATI Technologies, Inc. RV280 [Radeon 9200 PRO]"

Driver "ati"

BusID "PCI:1:0:0"

EndSection

Section "Monitor"

Identifier "AL1917W"

Option "DPMS"

Modeline "1440x900" 89.100 1440 1496 1528 1600 900 903 909 926 +hsync +vsync

EndSection

Section "Screen"

Identifier "Default Screen"

Device "ATI Technologies, Inc. RV280 [Radeon 9200 PRO]"

Monitor "AL1917W"

DefaultDepth 24

SubSection "Display"

Depth 1

Modes "1440x1440" "1400x1050" "1280x1280" "1280x1024" "1280x960" "1152x921" "1152x864" "1024x768" "832x624" "800x600" "720x400" "640x480"

EndSubSection

SubSection "Display"

Depth 4

Modes "1440x1440" "1400x1050" "1280x1280" "1280x1024" "1280x960" "1152x921" "1152x864" "1024x768" "832x624" "800x600" "720x400" "640x480"

EndSubSection

SubSection "Display"

Depth 8

Modes "1440x1440" "1400x1050" "1280x1280" "1280x1024" "1280x960" "1152x921" "1152x864" "1024x768" "832x624" "800x600" "720x400" "640x480"

EndSubSection

SubSection "Display"

Depth 15

Modes "1440x1440" "1400x1050" "1280x1280" "1280x1024" "1280x960" "1152x921" "1152x864" "1024x768" "832x624" "800x600" "720x400" "640x480"

EndSubSection

SubSection "Display"

Depth 16

Modes "1440x1440" "1400x1050" "1280x1280" "1280x1024" "1280x960" "1152x921" "1152x864" "1024x768" "832x624" "800x600" "720x400" "640x480"

EndSubSection

SubSection "Display"

Depth 24

Modes "1440x900" "1280x960" "1152x921" "1152x864" "1024x768" "832x624" "800x600" "720x400" "640x480"

EndSubSection

EndSection

Section "ServerLayout"

Identifier "Default Layout"

Screen "Default Screen"

InputDevice "Generic Keyboard"

InputDevice "Configured Mouse"

InputDevice "stylus" "SendCoreEvents"

InputDevice "cursor" "SendCoreEvents"

InputDevice "eraser" "SendCoreEvents"

EndSection

Section "DRI"

Mode 0666

EndSection

Share this post


Link to post
Share on other sites

That appears to be your old xorg file that you used with your ati card. Do you already have you nvidia card installed? I need the xorg file that corresponds with the new card.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...